Notices
M-Class (W164) 2006-2011: ML280CDI, ML320CDI, ML420CDI, ML350, ML500, ML550

2007 ml350

 
Old 03-15-2019, 04:02 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
2007 ml350

Hello all. Having an issue with my 07 ml350. The doors apparently keep locking. When I drive they will lock and then unlock and keep unlocking. When its off. I hear the locks continue to lock. All the locks are doing it and cant figure out the issue. Anyone have an idea?
richrom2 is offline  
Old 03-15-2019, 04:31 PM
  #2  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500

Please UPDATE YOUR PROFILE in USER CP to include the year, model and where you live.
Maj. Dundee is offline  
Old 03-15-2019, 04:33 PM
  #3  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Does this locking & unlocking occur after the speed of 9 MPH?
Maj. Dundee is offline  
Old 03-15-2019, 05:02 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Originally Posted by Maj. Dundee View Post
Does this locking & unlocking occur after the speed of 9 MPH?

It will lock automatically when I begin to drive. After a few minutes it will then all unlock and continue unlocking. For instance, right now it's off and in my driveway and I can hear the locks clicking.
richrom2 is offline  
Old 03-15-2019, 05:20 PM
  #5  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Why did you ignore the updating of your profile? It was a simple request.
Maj. Dundee is offline  
Old 03-15-2019, 05:52 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Originally Posted by Maj. Dundee View Post
Why did you ignore the updating of your profile? It was a simple request.
My apologies didn't even notice that
richrom2 is offline  
Old 03-15-2019, 05:55 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
How do I go about updating it
richrom2 is offline  
Old 03-15-2019, 06:00 PM
  #8  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Originally Posted by richrom2 View Post
How do I go about updating it
Good Lord I provided you with the instructions. What more do you want?
Maj. Dundee is offline  
Old 03-15-2019, 06:01 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
I got it. On phone and have to put it on desktop mode to see CP user
richrom2 is offline  
Old 03-15-2019, 06:10 PM
  #10  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500



OK, with the key out of the ignition, remove fuse #14 in the right side instrument panel fuse box and see if the locks stop actuating. Pull off the rubber door seal first then pry open the fuse door.
Attached Files
Maj. Dundee is offline  
Old 03-15-2019, 06:26 PM
  #11  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
I pulled the fuse and it stopped. Also, why would the lock and unlock switch inside not work?
richrom2 is offline  
Old 03-15-2019, 06:50 PM
  #12  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
A quick guess would be because of the problem you are having.

What happens when you reinsert the fuse?

I believe you have a problem with the EIS,Electronic Ignition Switch, where you insert the key.

Is your CEL on?
Maj. Dundee is offline  
Old 03-15-2019, 07:01 PM
  #13  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
When reinserted the fuse it started back up again. What is the cel?
richrom2 is offline  
Old 03-15-2019, 07:49 PM
  #14  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Check engine light is not on.
richrom2 is offline  
Old 03-16-2019, 03:26 AM
  #15  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Did you recently buy this truck and what was the date?

Reinsert fuse #14. Turn key to the on position. Does your CEL illuminate and then goes out?

Remove key and with all doors closed, open tailgate and go to fuse box and remove fuse #40. Check to see that it is not blown. Close tailgate. Did the unlock and locking stop? If not, reinsert fuse 40 and close tailgate.

Then perform the same procedure with fuses 26 and 34.
Attached Files
Maj. Dundee is offline  
Old 03-16-2019, 01:26 PM
  #16  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
I removed #40 fuse. The gate did not operate but I all of a sudden was able to use the lock and unlock buttons inside. I checked the other 2 fuses and they were fine. I put the 40 fuse back and ran some errands and the locking didnt occur. After about 2 hours while driving, the locks unlocked.
richrom2 is offline  
Old 03-16-2019, 02:06 PM
  #17  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
It's very annoying that I ask you a question and you do not answer it. Turn key to the on position. Does your CEL illuminate and then goes out?
Maj. Dundee is offline  
Old 03-16-2019, 04:11 PM
  #18  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Some of my messages must not be going through. Good ol' Sprint service. Yes, when the vehicle is on the check engine engine lights goes out.
richrom2 is offline  
Old 03-16-2019, 05:27 PM
  #19  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Another thing also, when I go to unlock the truck to go in it. I will unlock and then it will automatically lock again real fast.
richrom2 is offline  
Old 03-17-2019, 01:43 AM
  #20  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Without having the codes read with a scanner, my guess would be you need a new tailgate lock.

I strongly suggest that you buy a scanner code reader and check for codes in the entire truck.

Amazon Amazon
Maj. Dundee is offline  
Old 03-17-2019, 07:20 AM
  #21  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
I do have one. Would it still read codes even with the cel off?
richrom2 is offline  
Old 03-17-2019, 07:53 AM
  #22  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 3,903
Thanked 329 Times in 316 Posts
2002 ML 320 & 2006 ML500
Again you are not being informative. Which one do you have?

Only certain problems will illuminate the CEL.
Maj. Dundee is offline  
Old 03-18-2019, 07:32 AM
  #23  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
My apologies. All you stated was that I should get a scanner. You never gave any specifics on which one I should get or have so I just assumed that any type of scanner reader would have been fine. I'll check on which one I have.
richrom2 is offline  
Old 03-18-2019, 07:51 AM
  #24  
Member
 
texterted's Avatar
 
Join Date: Apr 2017
Location: UK
Posts: 130
Thanked 10 Times in 10 Posts
ML420 W164 (2009)
He did provide a link to the one he suggested!
texterted is online now  
Old 03-18-2019, 07:55 AM
  #25  
Junior Member
Thread Starter
 
Join Date: Oct 2011
Location: Greenwich Twp, NJ
Posts: 45
Thanks: 0
Thanked 0 Times in 0 Posts
2007 ml350 and 2004 clk320
Originally Posted by texterted View Post
He did provide a link to the one he suggested!
I pressed the amazon link and it doesnt open. I assumed it was just a suggested site. I thank everyone for there help.and patience. Please forgive my ignorance.
richrom2 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: 2007 ml350


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: