Notices
W211 AMG Discuss the W211 AMG's such as the E55 and the E63
Sponsored by:
Sponsored by:

w211 radio cutting in and out every 5 minutes

 
Old 03-12-2017, 02:36 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
w211 radio cutting in and out every 5 minutes

Update: Fixed! I cut out the navigations cd drive with a fiberoptic loop, thanks guys!

I just bought a new to me e55, so I am sorry I will be bombarding with a few questions

my stereo cuts out for 1-3 seconds every 5-10 minutes. the screen does not flash. sometimes it happens with a high pitched squeal especially when in AUX mode. In FM mode it just goes quiet for the same 1-3 seconds

also sometimes when it comes back on not all the speakers work, then it will cut back out and in and they will all work.

I kind of think it may be the amp but, thats just my guess.

I also have the battery protection warning that some convience functions are limited that toggles on and off.

Last edited by 65cobra; 03-17-2017 at 01:34 PM. Reason: update
65cobra is offline  
Old 03-12-2017, 02:43 PM
  #2  
Member
 
Join Date: Jun 2010
Location: South Jersey
Posts: 81
Received 4 Likes on 3 Posts
2010 E63AMG
Sounds like it may be time to change out your auxiliary battery. It is up front passenger side on the firewall underneath the cabin air filter. It's primary purpose is to be a back up for your sbc breaking system but when they start to go you get the convenience features disabled message. Uncover it and check the voltage and go from there. GL.
verminator is offline  
Old 03-12-2017, 02:56 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
hopefully thats it I just posted another thread, its an ever ready battery probably from walmart I could not find a date code on it but it has 12.5 volts when its disconnected and 13.95 when its connected and the car is at idle. it seems to be okay. the trunk battery is most suspect its at 12.18 disconnected and 13.88 when connected at idle.
65cobra is offline  
Old 03-12-2017, 03:25 PM
  #4  
Member
 
Join Date: Jun 2010
Location: South Jersey
Posts: 81
Received 4 Likes on 3 Posts
2010 E63AMG
Those numbers sound OK. Did the car sit for a while before you bought it? Maybe just charge them up. Other things that will silence the radio are the telaid being inoperative, also gives you a message on the display. The car is sensitive to the battery voltages, so if it sat and they discharged the issue may go away..?
verminator is offline  
Old 03-13-2017, 04:43 PM
  #5  
MBWorld Fanatic!
 
BagMan's Avatar
 
Join Date: Jan 2010
Location: SWFL
Posts: 1,057
Received 16 Likes on 12 Posts
E55, E320 CDI , CLA250, Jag XJ Supersport
I had this problem and it turned out to be the factory bluetooth. I just removed the BT module from the MOST ring. It's in the trunk.

Drove me crazy for months. Replaced the head unit, amp, nav but it still happened.

If you don't have the factory phone & bluetooth, forget everything I just said.

Good Luck!
BagMan is offline  
Old 03-14-2017, 12:18 AM
  #6  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
I am thinking it some short in the system, it does not happen when I am parked just when I am driving

I replaced the big battery today still same error code so I don't think its anything to do with that.

how do I take stuff out of the most ring, the sirius box was not bolted down and was flopping around..... I don't need the nav stuff either.

ok I found a fiber loop, for $8 on amazon Ill start skipping stuff and see If I can find the culprit

Last edited by 65cobra; 03-14-2017 at 12:26 AM.
65cobra is offline  
Old 03-14-2017, 01:29 AM
  #7  
MBWorld Fanatic!
 
Rocman8's Avatar
 
Join Date: Nov 2014
Posts: 1,139
Received 67 Likes on 63 Posts
2006 E55, 2005 C55, 2005 E320 Estate Sport, 2015 ML350
Start with software updates on the comand and audio gateway. Fixes 90 percent of them. Go to a dealer and have someone do it that's done it before.
Rocman8 is offline  
Old 03-14-2017, 11:36 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
I think my next step is waiting for the fiber optic loop to come but while searching the headunit on car-part using the vin search my current headunit is not listed as one of the options, could that be part of the problem?

here is a pic of the tag
Attached Thumbnails w211 radio cutting in and out every 5 minutes-20170311_175134479_ios.jpg  
65cobra is offline  
Old 03-17-2017, 01:35 PM
  #9  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
Fixed put a fiberoptic loop in the nav, cd player in the trunk and it stopped cutting out. on to the next things.....

Thanks for all the help
65cobra is offline  
Old 02-24-2018, 12:07 PM
  #10  
Newbie
 
Join Date: Feb 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
2006 E350 4msticwagon
Originally Posted by 65cobra View Post
Fixed put a fiberoptic loop in the nav, cd player in the trunk and it stopped cutting out. on to the next things.....

Thanks for all the help
Do you have a photo of how you did that? Thank you
Lee Gregory is offline  
Old 02-24-2018, 11:44 PM
  #11  
Junior Member
Thread Starter
 
Join Date: Feb 2017
Posts: 57
Received 2 Likes on 2 Posts
2006 e55
I dont have a pic but basically i unplugged the nav cd player fiber optic wire and plugged a loop into the fiber optic cable. so essentially I bypassed the nav.

Amazon Amazon
65cobra is offline  
Old 03-04-2018, 03:10 AM
  #12  
Member
 
mondo's Avatar
 
Join Date: Aug 2017
Location: Australia
Posts: 196
Received 19 Likes on 15 Posts
2003 W211 E55 AMG
This just started happening to me this weekend. so frustrating! this thread will be very helpful, thanks.
mondo is offline  
Old 05-04-2018, 10:56 PM
  #13  
Junior Member
 
scott099's Avatar
 
Join Date: Mar 2018
Posts: 62
Received 1 Like on 1 Post
E500
I'm having the same problem! happens ONLY when I'm driving the audio will cut out. doesn't matter if its radio, cd, cdc. if I'm parked the audio runs non-stop no problem. glad I found this thread and hope that loop fixes mine too
scott099 is offline  
Old 05-06-2018, 06:38 AM
  #14  
Member
 
mondo's Avatar
 
Join Date: Aug 2017
Location: Australia
Posts: 196
Received 19 Likes on 15 Posts
2003 W211 E55 AMG
mine has actually stopped doing it. absolutely no idea why?
mondo is offline  
Old 05-08-2018, 04:14 PM
  #15  
Junior Member
 
scott099's Avatar
 
Join Date: Mar 2018
Posts: 62
Received 1 Like on 1 Post
E500
I'm happy to report this fixed mine too!

I installed the fiber optic loop bypass on the navigation, no more cutting out! before it would cut out almost exactly once a minute only when driving. it didn't matter the source - radio, cd, cdc, didn't matter the volume or anything else. just when driving. immediately after installing the bypass on the nav the audio will play non-stop again.

Thank you so much!!
scott099 is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: w211 radio cutting in and out every 5 minutes


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: