Android 10.25 Screen Unit - Page 4 - MBWorld.org Forums

Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Android 10.25 Screen Unit >

Android 10.25 Screen Unit

Notices
C-Class (W204) 2008-Present: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Android 10.25 Screen Unit

Old 03-22-2018, 05:09 AM
  #76  
Member
 
Join Date: Mar 2010
Posts: 209
Thanks: 0
Thanked 7 Times in 7 Posts
2011 C300 Luxury
Originally Posted by Chris The Swede View Post
I have no issues whats so ever.
That concerns me, I wonder what is wrong with my unit then..? Streaming Pandora is perfect.
I’ll make a video tomorrow.. I wonder what I can do to try and fix it.
95Sinned420 is offline  
Old 03-22-2018, 05:31 AM
  #77  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by Chris The Swede View Post
I have no issues whats so ever.
My Google maps is lagging very much. Its not smooth like in the video someone linked. When i drive and navigate the arrow will move for 2 sec and stop, move and stop, and so on. and takes 1 minuted to do anything in the app :O

Very strange, other apps are working well. And Waze it smooth.
adro92 is offline  
Old 03-22-2018, 05:33 AM
  #78  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 139 Times in 108 Posts
W212 E63 wagon, ML350, GLK 350
Sounds like memory loss or something..
Chris The Swede is offline  
Old 03-22-2018, 05:37 AM
  #79  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by Chris The Swede View Post
Sounds like memory loss or something..
Maybe, but its strange that it doesnt happen to everyone. Since the units have the same memory.
adro92 is offline  
Old 03-22-2018, 05:44 AM
  #80  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 139 Times in 108 Posts
W212 E63 wagon, ML350, GLK 350
Well might depend on how many apps you downloaded for exmple.
Chris The Swede is offline  
Old 03-22-2018, 06:03 AM
  #81  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by Chris The Swede View Post
Well might depend on how many apps you downloaded for exmple.
Could try moving it so SD card.

(Tror du har mail från mig förresten, ang. mitt ordernr )
adro92 is offline  
Old 03-22-2018, 06:05 AM
  #82  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 139 Times in 108 Posts
W212 E63 wagon, ML350, GLK 350
Inget obesvarat?
Chris The Swede is offline  
Old 03-22-2018, 06:09 AM
  #83  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by Chris The Swede View Post
Inget obesvarat?
Kom aldrig något svar efter jag skickade mitt ordernr. Men skickar ett nytt.
adro92 is offline  
Old 03-22-2018, 10:20 PM
  #84  
Newbie
 
Join Date: Oct 2007
Location: Los Angeles, CA
Posts: 8
Thanked 0 Times in 0 Posts
C300
For those that have installed the unit, I'm curious how you guys were able to fit the command unit back in with all the new wires. There's almost no room to hide all the wires and it's nearly impossible to put the command back. Any tips?
xliltimcuzx is offline  
Old 03-23-2018, 03:02 AM
  #85  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by xliltimcuzx View Post
For those that have installed the unit, I'm curious how you guys were able to fit the command unit back in with all the new wires. There's almost no room to hide all the wires and it's nearly impossible to put the command back. Any tips?
What I did was made sure the big square connector was under the command unit. Thats what preventing the command to sit further if it's stuck behind it. Had to use a long wrench (solid metal ruler probably would work better). Get that big square connector tucked under before you push the command in. Look under the command as you are pushing the command in. There should be enough space to see the connector and for the ruler or wrench to get in there. Use the ruler to make sure the square connector stays under by pushing down on it.

If you squish this connector behind the command you will have issues as I did. My command screen would intermittently not show up on the android screen. Took me weeks to figure out my issue
aznmode is offline  
The Following 2 Users Say Thank You to aznmode For This Useful Post:
Christophe (09-05-2018), xliltimcuzx (03-26-2018)
Old 03-23-2018, 03:21 AM
  #86  
Member
 
Join Date: Mar 2010
Posts: 209
Thanks: 0
Thanked 7 Times in 7 Posts
2011 C300 Luxury
Originally Posted by xliltimcuzx View Post
For those that have installed the unit, I'm curious how you guys were able to fit the command unit back in with all the new wires. There's almost no room to hide all the wires and it's nearly impossible to put the command back. Any tips?
Bottom right of this pic, you have the wires running through the hole. It needs
to go behind the frame of that hole, otherwise the command unit will slide along the track and pinch the wires against the frame. I ran into this same issue but figured it out.
95Sinned420 is offline  
The Following User Says Thank You to 95Sinned420 For This Useful Post:
xliltimcuzx (03-26-2018)
Old 03-23-2018, 02:18 PM
  #87  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by 95Sinned420 View Post
I installed the extra antenna today and did rear camera install as well, everything is done now.
No improvement on Bluetooth audio streaming...I mean, after all it wasn't the Bluetooth antenna lol

Google maps works for me, I mean, it's accurate. It's just very slow, seems to be that the unit cannot run it due to lack of performance, or that google map's app is just a performance hog.

Everything works except the annoying freeze/stutter I get from Bluetooth audio streaming.
Can someone on here confirm that they can play music through bluetooth from their phone without any issues? I keep getting stuttering, even when I am not running any other apps. It comes and goes and interrupts the music, very annoying.
Try this, play music from your phone via Bluetooth streaming, then run navigation (for me, its Waze) and while Waze is loading, the music stutters/lags, due to a performance hit while launching the GPS app I assume? The thing is, it also happens when I am not doing anything else...performance shouldn't take a hit.
I get no audio when I stream. Using Google play music or YouTube on my phone. It shows on the display and I can pause, forward but no sound. I know the sound is on because when I open up waze,YouTube on the android screen, I hear sound.



Volume at max on my phone
aznmode is offline  
Old 03-23-2018, 03:05 PM
  #88  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by aznmode View Post
I get no audio when I stream. Using Google play music or YouTube on my phone. It shows on the display and I can pause, forward but no sound. I know the sound is on because when I open up waze,YouTube on the android screen, I hear sound.



Volume at max on my phone
It's the same way for me..
adro92 is offline  
Old 03-27-2018, 04:09 AM
  #89  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Just found out there is a built in mic on this device. I didn't need to buy an external one.


Last edited by aznmode; 03-27-2018 at 01:51 PM.
aznmode is offline  
Old 03-27-2018, 05:05 AM
  #90  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 139 Times in 108 Posts
W212 E63 wagon, ML350, GLK 350
Chris The Swede is offline  
Old 03-27-2018, 01:35 PM
  #91  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by aznmode View Post
Just found out there is a built in mic on this device. I didn't need to buy an external one.
Does it work, my unit won't even allow me to use voice commands in Maps, waze etc.
adro92 is offline  
Old 03-27-2018, 01:47 PM
  #92  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by adro92 View Post
Does it work, my unit won't even allow me to use voice commands in Maps, waze etc.
Works on waze for me but I do have to speak a little louder and more clearer. Haven't tried it in any other app yet. Will post a video later.

UPDATE: For the built in mic to work on google maps, play store, or any app where you have the mic icon (not needed for Waze), you will need to install the google app. This also will make the voice button work on swiftkey keyboard.

Last edited by aznmode; 03-27-2018 at 06:56 PM.
aznmode is offline  
Old 03-27-2018, 01:48 PM
  #93  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by Chris The Swede View Post
👍 thanks Chris!
aznmode is offline  
Old 03-29-2018, 12:35 AM
  #94  
Junior Member
 
Join Date: Apr 2017
Posts: 28
Thanked 3 Times in 2 Posts
2014 Mercedes-Benz E350 4Matic Sedan
Originally Posted by aznmode View Post
I was able to move youtube (200+mb) to sd card. So I can only assume I've made room for only that much. So I am still limited to downloading any app larger than 200gb. Which is good for now as most app I want to install are less than that. I just need to keep moving them to sd after install.

Since I'm rooted, if remember back in the old android days I was able to make storage the internal storage so potentially I can increase my storage to 32gb. I will try to see if it will recognize a 64gb then that's even more room.
Have you tried installing 'Android Auto'? I haven't read enough about Android Auto, but I see APK's available for Android 5.0+...I'm wondering if these will work.
Have you tried automating anything (for example - auto-launch Spotify) using Tasker or similar?
Any other noteworthy app-based mods?
deepthought66 is offline  
Old 03-29-2018, 02:39 PM
  #95  
MBWorld Fanatic!
Thread Starter
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,307
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by deepthought66 View Post
Have you tried installing 'Android Auto'? I haven't read enough about Android Auto, but I see APK's available for Android 5.0+...I'm wondering if these will work.
Have you tried automating anything (for example - auto-launch Spotify) using Tasker or similar?
Any other noteworthy app-based mods?

I haven't installed android auto as I didn't feel the need to since I can run more apps using with the stock android. Also haven't used tasker since I can't think of anything I want to autorun each power on. As far as other apps, besides the one's I've already posted here, I have not downloaded anything else. Do you have this unit or just thinking of getting it?
aznmode is offline  
Old 03-30-2018, 10:39 PM
  #96  
Super Member
 
benzdude's Avatar
 
Join Date: Nov 2003
Location: Earth
Posts: 547
Thanked 25 Times in 25 Posts
2015 C300 4Matic Sport
Any info on how firmware updates are provided? Was there a "MPH" update yet?
benzdude is offline  
Old 03-30-2018, 10:44 PM
  #97  
Super Member
 
benzdude's Avatar
 
Join Date: Nov 2003
Location: Earth
Posts: 547
Thanked 25 Times in 25 Posts
2015 C300 4Matic Sport
Talking

Originally Posted by adro92 View Post

​​​​
For a second I thought your car had 175,000 miles on it. (still 108k miles) looks good.
benzdude is offline  
Old 03-31-2018, 04:12 AM
  #98  
MBWorld Fanatic!
 
Chris The Swede's Avatar
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 139 Times in 108 Posts
W212 E63 wagon, ML350, GLK 350
Originally Posted by benzdude View Post
Any info on how firmware updates are provided? Was there a "MPH" update yet?
When and if its done I will provide it to my customers. Just send me an email.
Chris The Swede is offline  
Old 03-31-2018, 05:16 AM
  #99  
Member
 
Join Date: Jun 2017
Location: Sälen
Posts: 95
Thanks: 0
Thanked 6 Times in 6 Posts
C180 Kompressor (2008)
Originally Posted by benzdude View Post
For a second I thought your car had 175,000 miles on it. (still 108k miles) looks good.
It's nothing, unless you have a French car
I drive about 18000 miles per year.
​​​​​Had a 2013 Vito that did about 435 000 miles before it was sold. Still had the same automatic 5 speed gearbox and same engine lol. Was a work car for transport.

​​
adro92 is offline  
Old 03-31-2018, 03:11 PM
  #100  
Junior Member
 
bigrob126's Avatar
 
Join Date: Aug 2016
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
2013 Mercedes C250 Coupe
I like this idea, but would rather just want the larger screen and touch screen capabilities, and extend my OEM format, rather than all the google play stuff.

Last edited by bigrob126; 03-31-2018 at 03:14 PM.
bigrob126 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Android 10.25 Screen Unit


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: