Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > GL Class (X164)
GL450 Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System >

GL450 Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System

Notices
GL Class (X164) 2007-2012: GL320CDI, GL420CDI, GL450, GL550

GL450 Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System

 
Old 09-15-2018, 02:35 PM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 8
Liked 2 Times in 1 Post
2007 GL450
Smile GL450 Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System

I learned of this aftermarket radio on this forum. Just wanted to pay it forward. I have a 2007 gl450, which I ordered this Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System multimedia navigation head unit for. Had it installed today at PhD electronics in Chicago (22nd and Pulaski rd.). It works like a charm; makes the vehicle look modern and up to date. It's like have an android tablet installed in your vehicle. Highly recommended!
Henry Hemphill is offline  
Old 09-16-2018, 01:16 PM
  #2  
Member
 
Yup497's Avatar
 
Join Date: Oct 2017
Location: Saint Louis
Posts: 77
Likes: 0
Liked 6 Times in 6 Posts
2010 GL550
Any photos? I'm intrigued. Can I keep my satellite radio?
Yup497 is online now  
Old 09-16-2018, 01:59 PM
  #3  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 8
Liked 2 Times in 1 Post
2007 GL450
I will upload photos when I get home. It's like a cellphone or tablet, so I would image you could download the satellite radio app. But you want need satellite unless you just want it.
Henry Hemphill is offline  
Old 09-16-2018, 02:44 PM
  #4  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 8
Liked 2 Times in 1 Post
2007 GL450
Aftermarket radio photos









Henry Hemphill is offline  
The following 2 users liked this post by Henry Hemphill:
2008 ML 320 CDI (02-02-2019), a2j (10-02-2018)
Old 09-16-2018, 03:17 PM
  #5  
Member
 
Yup497's Avatar
 
Join Date: Oct 2017
Location: Saint Louis
Posts: 77
Likes: 0
Liked 6 Times in 6 Posts
2010 GL550
Looks great! Thanks for posting!
Yup497 is online now  
The following users liked this post: Yup497
Henry Hemphill (09-18-2018)
Old 09-16-2018, 06:30 PM
  #6  
Junior Member
 
Join Date: Oct 2016
Posts: 51
Likes: 0
Liked 0 Times in 0 Posts
2013 VW Passat, 2011 Audi A8L, 2008 GL 320 CDI, 2005 C230 Kompressor, 2001 M3
If you dont mind sharing, how much did it cost you with installation?
Dinismb is offline  
Old 09-16-2018, 06:48 PM
  #7  
Newbie
Thread Starter
 
Join Date: Mar 2017
Posts: 8
Liked 2 Times in 1 Post
2007 GL450
Installation

The unit is listed on avinusa.com. They bost that itís plug and play. I tried, it was a little more difficult than that. I went to PhD electronics and paid $280 because I also bought the back up camera. Just the head unit is about $150-$180.

The unit nit by itself is $389
Henry Hemphill is offline  
Old 09-18-2018, 11:04 AM
  #8  
Junior Member
 
Join Date: Aug 2018
Posts: 33
Liked 3 Times in 2 Posts
GL550
ordered the same unit too this weekend and I received it yesterday. Super fast shipping! Of course it helps that it came from SoCal and I live in NorCal. I bought all the adapters for the factory back up cam, gps antenna, and microphone. I even got the Carplay adapter. Hopefully it is plug and play for me since I got all the adapters they suggested. I will be installing later this week and sharing photos when I can too. Looking forward to it as I have an android unit on my Nissan Titan and love everything about it.
PopoySD is offline  
The following users liked this post: PopoySD
Henry Hemphill (09-18-2018)
Old 09-18-2018, 01:29 PM
  #9  
Junior Member
 
Join Date: Oct 2016
Posts: 51
Likes: 0
Liked 0 Times in 0 Posts
2013 VW Passat, 2011 Audi A8L, 2008 GL 320 CDI, 2005 C230 Kompressor, 2001 M3
Originally Posted by Henry Hemphill View Post
The unit is listed on avinusa.com. They bost that itís plug and play. I tried, it was a little more difficult than that. I went to PhD electronics and paid $280 because I also bought the back up camera. Just the head unit is about $150-$180.

The unit nit by itself is $389
Thats awesome.
The speakers, do they sound the same as stock?
Did you not have a stock backup camera?
Dinismb is offline  
Old 09-19-2018, 10:17 PM
  #10  
Senior Member
 
Join Date: Jan 2013
Posts: 320
Liked 13 Times in 10 Posts
2011 GL350
wonder if the steering wheel controls will still work if you get the adaptors?
KrustyKustom is offline  
Old 09-20-2018, 02:08 AM
  #11  
Junior Member
 
Join Date: Aug 2018
Posts: 33
Liked 3 Times in 2 Posts
GL550
I just installed mine today. I have a 2012 GL550 with the Harman Kardon system. So I got the MOST fiber optic adapter, factory mic adapter, factory back up cam adapter, CarPlay adapter, as well as the factory gps antenna adapter (which I didn't need because the factory plug was compatible wth the unit and snapped right in. Steering wheel controls work pretty well.

The he only thing I couldn't get to work properly was the radio...for the OP, do you know if the place that installed your unit did anything specific to hook up the radio? I can't find a standard radio antenna like I've seen on other cars, and there was one I noticed that may be the radio antenna, but when I plugged it to the back of the unit, there was barely any stations it could pick up.

I didnt finish the the whole thing because nightfall came, but I'll wrap it up tomorrow and take pictures.

Last edited by PopoySD; 09-20-2018 at 02:09 AM. Reason: Added more info
PopoySD is offline  
The following 2 users liked this post by PopoySD:
2008 ML 320 CDI (02-02-2019), quron_southwest (12-22-2018)
Old 12-13-2018, 03:25 PM
  #12  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
After an aborted Pioneer install I'm looking at this unit. https://avinusa.com/mercedes-benz-ml...on-system.html

I'm told I can connect wirelessly via wifi with an iPhone and use Airplay or wired with the Carplay adaptor. I prefer wireless connection, but would like to know if the unit 'remembers' the Airplay hookup each time the car is started or if it requires steps to connect via Airplay?

Anyone have experience with this?

Last edited by Diamondrichlb; 12-13-2018 at 05:24 PM.
Diamondrichlb is offline  
The following users liked this post: Diamondrichlb
2008 ML 320 CDI (02-02-2019)
Old 12-19-2018, 10:45 AM
  #13  
Junior Member
 
Join Date: Dec 2018
Posts: 41
Liked 6 Times in 6 Posts
GL 550
Bought and installed this same unit (w/ back up camera, factory mic, and HK Fiber adaptor) and did the install myself over the weekend, and so far I love it. Great upgrade....unit works flawless and sounds great. Most of all I can stream video (espn, news, games, movies, etc) while sitting in traffic... highly recommended. Only issues thus far is no FM reception, but I am pretty sure I figured out why and have an adapter on the way. You lose a bit of functionality from the Command center, like Nav info doesnt show up in the center display. I use Waze now, so who cares?!?!?! Also you can no longer broadcast video to the rear monitors, but whatever. Its all about the first class (not coach) seats in my GL anyway.....LOL.

Definitely worth the money, and the install was pretty much plug in play, didnt have to cut 1 wire.

Last edited by Iceytys; 12-19-2018 at 10:47 AM.
Iceytys is offline  
The following users liked this post: Iceytys
2008 ML 320 CDI (02-02-2019)
Old 12-19-2018, 04:04 PM
  #14  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
Originally Posted by Iceytys View Post
Bought and installed this same unit (w/ back up camera, factory mic, and HK Fiber adaptor) and did the install myself over the weekend, and so far I love it. Great upgrade....unit works flawless and sounds great. Most of all I can stream video (espn, news, games, movies, etc) while sitting in traffic... highly recommended. Only issues thus far is no FM reception, but I am pretty sure I figured out why and have an adapter on the way. You lose a bit of functionality from the Command center, like Nav info doesnt show up in the center display. I use Waze now, so who cares?!?!?! Also you can no longer broadcast video to the rear monitors, but whatever. Its all about the first class (not coach) seats in my GL anyway.....LOL.

Definitely worth the money, and the install was pretty much plug in play, didnt have to cut 1 wire.
Great that itís working for you. What type phone are you using? Android or IOS?
Diamondrichlb is offline  
Old 12-19-2018, 04:07 PM
  #15  
Junior Member
 
Join Date: Dec 2018
Posts: 41
Liked 6 Times in 6 Posts
GL 550
Well an Android of course!
Iceytys is offline  
Old 12-19-2018, 04:13 PM
  #16  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
Of course. I’m going to try it with IOS
Diamondrichlb is offline  
Old 12-19-2018, 07:22 PM
  #17  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
Installed the unit.

Can't get the backup camera or microphone to work. I'm using the supplied pigtails purchased from AVIN. When car put in reverse, the backup camera is showing as a black screen with a small square with a triangle inside that with an ! inside that.

Can you tell me what inputs you used on the head unit and the car to get these 2 devices to work?
Diamondrichlb is offline  
Old 12-19-2018, 10:37 PM
  #18  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 92
Liked 1 Time in 1 Post
2009 GL550 ; 2005 Lexus LS430
Only issues thus far is no FM reception, but I am pretty sure I figured out why and have an adapter on the way.

Definitely worth the money, and the install was pretty much plug in play, didnt have to cut 1 wire.[/QUOTE]

If you figure out why you don't have FM reception, please pass it along. Most of us that installed this unit lost our FM reception.
rich30769 is offline  
Old 12-19-2018, 10:40 PM
  #19  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 92
Liked 1 Time in 1 Post
2009 GL550 ; 2005 Lexus LS430
Originally Posted by Diamondrichlb View Post
Installed the unit.

Can't get the backup camera or microphone to work. I'm using the supplied pigtails purchased from AVIN. When car put in reverse, the backup camera is showing as a black screen with a small square with a triangle inside that with an ! inside that.

Can you tell me what inputs you used on the head unit and the car to get these 2 devices to work?
Mic seems to be hit, or miss. It works for some people but, not for others. Also, I'm having a bit of an issue connecting to my phones hotspot. Sometime it connects right away, sometimes it takes minutes to connect.
rich30769 is offline  
Old 12-20-2018, 01:13 AM
  #20  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
There was a note in my install that said Amp-Com had to connect to Ant. Did you make that connection? When my harness came in the Amp-Con was connected to another Amp-con
Diamondrichlb is offline  
Old 12-20-2018, 01:18 AM
  #21  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
My iPhone is connecting via A2DP. There is an icon for that connection on the second page. I don't understand all I know about this entire hookup yet. I just installed it today.

I need the microphone and backup camera. Today, someone who should know, told me I might have to pull a new wire for the backup camera. Not good. I specifically ask about the camera and microphone before I bought the unit.
Diamondrichlb is offline  
Old 12-20-2018, 09:58 AM
  #22  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 92
Liked 1 Time in 1 Post
2009 GL550 ; 2005 Lexus LS430
Originally Posted by Diamondrichlb View Post
There was a note in my install that said Amp-Com had to connect to Ant. Did you make that connection? When my harness came in the Amp-Con was connected to another Amp-con
Yes, I have FM reception "sometimes" but definitely not like I should. If you remember the COMAND system has 2 farka inputs, this radio has 2 BUT, 1 is empty. That seems to be the problem
rich30769 is offline  
Old 12-20-2018, 10:00 AM
  #23  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 92
Liked 1 Time in 1 Post
2009 GL550 ; 2005 Lexus LS430
Originally Posted by Diamondrichlb View Post
My iPhone is connecting via A2DP. There is an icon for that connection on the second page. I don't understand all I know about this entire hookup yet. I just installed it today.

I need the microphone and backup camera. Today, someone who should know, told me I might have to pull a new wire for the backup camera. Not good. I specifically ask about the camera and microphone before I bought the unit.
My Android is connected to A2DP also, I can't hear the phone through the speaker system so, I end up using the phones speaker to answer my calls which defeats the hand free option.
As for the rear view camera, I got lucky and mine works with the adapter they sent me. There's a lot of hit, or miss with this radio.
I previously emailed AVIN with my issues and their solution to me was to return the radio for a full refund. Of course they want every little single box, styrofoam, twisty and whatever else came in the box back also. I happen to have all of that but, decided to just keep the system and deal with the phone and delay in connectivity issues.

Last edited by rich30769; 12-20-2018 at 10:04 AM.
rich30769 is offline  
Old 12-20-2018, 02:16 PM
  #24  
Newbie
 
Join Date: Dec 2018
Posts: 13
Likes: 0
Liked 1 Time in 1 Post
2011 ML 350
As I understand it, the FM antenna is the wire in the rear window. Not sure why that would be intermittent. You would think it would work or not.

I get the phone conversation over the car speakers, just no microphone production.

Still waiting for any response from AVIN after yesterday’s questions.

i like the unit. Looks good. Better than the Pioneer4400, in my opinion. I also like the connectivity between the phone and the unit.

I need my backup camera and microphone and don’t really want to pull wires to get it. Aaarrrggg
Diamondrichlb is offline  
Old 12-20-2018, 04:22 PM
  #25  
Member
 
Join Date: Jun 2002
Location: Staten Island,NY
Posts: 92
Liked 1 Time in 1 Post
2009 GL550 ; 2005 Lexus LS430
Originally Posted by Diamondrichlb View Post
As I understand it, the FM antenna is the wire in the rear window. Not sure why that would be intermittent. You would think it would work or not.

I get the phone conversation over the car speakers, just no microphone production.

Still waiting for any response from AVIN after yesterdayís questions.

i like the unit. Looks good. Better than the Pioneer4400, in my opinion. I also like the connectivity between the phone and the unit.

I need my backup camera and microphone and donít really want to pull wires to get it. Aaarrrggg
I definitely feel your pain and agree about how it updates the look of the cabin. I'm not sure if there's an update out for a lot of these issues, or not. I'm positive that there isn't

Last edited by rich30769; 12-20-2018 at 04:24 PM.
rich30769 is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: GL450 Mercedes-Benz ML GL 9" - 8.0 Oreo 4GB RAM Navigation System


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: