Go Back  MBWorld.org Forums > Mercedes-Benz SUVs, Trucks, Vans, Diesels, Other > M-Class (W163)
Help. All warning lights stay on after key removed & wont start >

Help. All warning lights stay on after key removed & wont start

Notices
M-Class (W163) 1998-2005: ML 230, ML 320, ML 350, ML 400 CDI, ML 430, ML 500, ML 270 CDI

Help. All warning lights stay on after key removed & wont start

 
Old 08-23-2017, 11:18 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2011
Location: So Cal
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2003 ML350. W163
Help. All warning lights stay on after key removed & wont start

So I washed my 2003 ml350 with a Garden hose. Etc. drove 10 miles parked, restarted. Drove 5 min. Parked. Drove 2 min. Parked. Restarted fine. After 2 min. Noticed the car turned off. When I tried to restart. All the warning lights on the dash came on and car wouldn't even crank. I took the key out and the warning lights stay on. It won't turn off until I disconnect the battery. Then the doors unlock via remote and lock alarm works to. Once I put the key in pos 2. The lights all come on hazards blink and vent starts blowing. I can't connect the Obd scanner ( generic ). It says vehicle not responding. The key won't lock or unlock the car until I disconnect the battery

I have Replaced relay 12 but same issue occurs.


Any help would be appreciated.

**** correction to title. Won't crank. *****

Last edited by narbo; 08-23-2017 at 11:28 PM. Reason: More info
narbo is offline  
Old 08-25-2017, 06:36 AM
  #2  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,315
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
Did you only wash the exterior with the hood closed?
Maj. Dundee is offline  
Old 08-25-2017, 03:01 PM
  #3  
Newbie
Thread Starter
 
Join Date: Sep 2011
Location: So Cal
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2003 ML350. W163
Originally Posted by Maj. Dundee View Post
Did you only wash the exterior with the hood closed?
Yes Hood closed.

it was washed and sat for an hour before I started driving.. the engine bay was dry. i did have some leaves in the hood / wiper area.. but no visable water in the interior
narbo is offline  
Old 08-28-2017, 12:55 PM
  #4  
Newbie
Thread Starter
 
Join Date: Sep 2011
Location: So Cal
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2003 ML350. W163
CPS was repalced and now car cranks, BUT still not 100%

Originally Posted by narbo View Post
So I washed my 2003 ml350 with a Garden hose. Etc. drove 10 miles parked, restarted. Drove 5 min. Parked. Drove 2 min. Parked. Restarted fine. After 2 min. Noticed the car turned off. When I tried to restart. All the warning lights on the dash came on and car wouldn't even crank. I took the key out and the warning lights stay on. It won't turn off until I disconnect the battery. Then the doors unlock via remote and lock alarm works to. Once I put the key in pos 2. The lights all come on hazards blink and vent starts blowing. I can't connect the Obd scanner ( generic ). It says vehicle not responding. The key won't lock or unlock the car until I disconnect the battery

I have Replaced relay 12 but same issue occurs.


Any help would be appreciated.

**** correction to title. Won't crank. *****

It cranked and started.. the strange thing is when I turn the key to position 2 the speedometer needle vibrates until the car turns on . also all the other gauges stay off for a good 30 sec after start and then become active.

any thoughts?
narbo is offline  
Old 08-29-2017, 09:47 AM
  #5  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,315
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
Remove the Instrument Cluster and its connector. Then try to replicate the problem and see if the problem still exists.
Attached Files
File Type: pdf
R&I Instrument Cluster.pdf (59.0 KB, 32 views)
Maj. Dundee is offline  
Old 09-05-2017, 06:17 PM
  #6  
Newbie
Thread Starter
 
Join Date: Sep 2011
Location: So Cal
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2003 ML350. W163
Originally Posted by Maj. Dundee View Post
Remove the Instrument Cluster and its connector. Then try to replicate the problem and see if the problem still exists.
So it turns out, it was the Crank position sensor.

i replaced it and it started right up... the only weird thing is that it takes a good 30 secs, for the gauges to activate ( Fuel and RPM ) and the speedometer shakes at startup.. and a weird ticking noise.

-Nick
narbo is offline  
Old 09-06-2017, 06:36 AM
  #7  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,315
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
With the hood closed water cannot effect the Crank Sensor.
Maj. Dundee is offline  
Old 10-11-2017, 08:52 PM
  #8  
Newbie
Thread Starter
 
Join Date: Sep 2011
Location: So Cal
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
2003 ML350. W163
Originally Posted by Maj. Dundee View Post
Remove the Instrument Cluster and its connector. Then try to replicate the problem and see if the problem still exists.


SO its been running fine for the last few days.. and today it turned off again while driving.. and i couldn't get it started. I did not wash it this time... so its definitely not the CPS. which i replaced.

I am going to try to remove the cluster and see if that does anything
narbo is offline  
Old 10-12-2017, 06:34 AM
  #9  
MBWorld Fanatic!
 
Join Date: Oct 2011
Location: Westchester, N.Y.
Posts: 4,315
Received 366 Likes on 351 Posts
2002 ML 320 & 2006 ML500
Removing the I.C. will do noting at this point. The problem does not occur often enough.

It's time to have the codes read with a professional grade scanner, not a code reader.

Last edited by Maj. Dundee; 10-12-2017 at 06:39 AM.
Maj. Dundee is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Help. All warning lights stay on after key removed & wont start


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: