Speaker Screeching.... Please Help! - MBWorld.org Forums

Notices
Audio & Electronics Use this forum to discuss audio and electronic upgrades for your Mercedes-Benz.

Speaker Screeching.... Please Help!

 
Old 02-07-2019, 11:58 AM
  #1  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
2012 C350 Sport
Speaker Screeching.... Please Help!

Mods: There is a duplicate thread in the W204 area. Let me know which location is more appropriate.

Hello everyone, I'm brand new to these boards. I bought a 2012 C350 Sport with 30,000 miles last week.

I've been super happy with the vehicle except something came up on my way to work this morning. I couldn't find anything anywhere on the internet regarding this issue, so I figured I would see if y'all knew what the issue could be. The rear speakers (I think it's the rear deck sub woofer/tweeter), started to crackle... about 10 minutes later an extremely high pitched screeching started to emanate from the rear of the car (It's unbearably loud). Attached is a video I recorded on my phone. It sounds like a grounding issue to me. Has anyone experienced anything like this? I'm not averse to popping a few panels to get at the wiring, just wondering if anyone had anything like this and looking to tap into some experience that someone else might have.

Many Thanks,
Attached Files
File Type: mov
Speaker Screech.mov (1.84 MB, 11 views)
5ardaukar is offline  
Old 02-11-2019, 12:18 PM
  #2  
Newbie
Thread Starter
 
Join Date: Feb 2019
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
2012 C350 Sport
Update:

The same day the rear deck speaker buzzing/screeching happened is the same day it stopped. However, whenever I open the car door, or start the engine, it briefly "chirps", as my wife puts it, with a very brief version of the high pitched buzz/screech. I got some body panel tools in this morning, so I'm going to remove the rear deck this weekend and see what it is. I have a feeling something isn't properly grounded, or the speaker is dead. I checked the rear amp in the trunk and everything is hooked up properly. I doubt the amp went bad, but it may have. I'll keep the thread updated in case anyone else has the same issue. I plan on removing the rear deck to get access to the speaker this weekend. If it's faulty wiring/connection, it should be an easy fix, if the speaker is dead, I'll have to find a replacement online, either new old-stock or used, probably used since it seems new old-stock goes for over $400 for the rear setup alone.

I'll also post photos.

If anyone wants to chime in and tell me what they're thinking, I'd really appreciate it.
5ardaukar is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Speaker Screeching.... Please Help!


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: