Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W203)
STUCK IN PARK, BAS/ESP, BRAKE LIGHT GO TO WORKSHOP >

STUCK IN PARK, BAS/ESP, BRAKE LIGHT GO TO WORKSHOP

Notices
C-Class (W203) 2001-2007, C160, C180, C200, C220, C230, C240, C270, C280, C300, C320, C230K, C350, Coupe

STUCK IN PARK, BAS/ESP, BRAKE LIGHT GO TO WORKSHOP

 
Old 10-02-2013, 06:35 PM
  #1  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
STUCK IN PARK, BAS/ESP, BRAKE LIGHT GO TO WORKSHOP

desperate need of some help please! Ok, i have a 2004 c320 4 matic. started out that the wipers and washer stopped working. so i assumed that a fuse was blown. i checked all the fuses in all three boxes trunk, under hood, driverside dash, all were good? i did pull all fuses out one at a time to check them. When i started the car back up i had a BAS/ESP light on dash and worse part the car is stuck in park? Also the brake light go to workshop code is there to and no interior lights? Im in a small town about 2 hrs from dealer? I have read nearly every thread on here concerning this problem and it all sounds like a brake light switch is the problem? So first of all there is nothing under my dash that looks like the switch shown on here. I also have been to parts house here and they list the same switch shown in these threads for the c320 but not the 4 matic? Is this different on my car and if so does anyone have any ideas? Im also assuming that the brake switch is not telling the shifter that the brake is pressed so it want let it go into gear? The brake lights do come on when the brake is pressed?
Thanks
Bobby
bobby.gina is offline  
Old 10-02-2013, 06:46 PM
  #2  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
also i forgot to mention that the ABS light is on too
bobby.gina is offline  
Old 10-02-2013, 08:01 PM
  #3  
MBWorld Fanatic!
 
Carsy's Avatar
 
Join Date: Mar 2008
Location: 1 hours drive north of Sydney Australia
Posts: 3,714
Received 42 Likes on 40 Posts
2007 W204 220CDI Classic Sedan
How old is your battery?. These cars are very susceptible to the type of errors you mention which are caused by a battery in poor condition. I would suggest to check the voltages with engine running & stopped & have a battery load test .

Good luck,
Carsy is offline  
Old 10-02-2013, 10:20 PM
  #4  
VVF
MBWorld Fanatic!
 
VVF's Avatar
 
Join Date: Sep 2011
Location: Austin, TX
Posts: 1,643
Received 22 Likes on 22 Posts
2005 C230K Sport Sedan
Maybe something happened to SAM when you were pulling those fuses?
I would check the battery as Carsy said, and try to reset the ABS etc errors with STAR...
VVF is offline  
Old 10-02-2013, 10:39 PM
  #5  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
Ok thanks,, hate to ask this but is star something that only a dealer has...I believe the battery is the original one,,, it could be a voltage issue but it has never failed to start or been sluggish,,,

And is this common for the shifter to be stuck in park...
Thank you for your replys
bobby.gina is offline  
Old 10-03-2013, 01:14 AM
  #6  
Super Member
 
Join Date: May 2009
Location: Toronto, Ontario, Canada, eh!
Posts: 904
Received 12 Likes on 11 Posts
2003 C230 Sports Coupe, Paprika Metallic Red, Auto, Pano, Leather
Yes,... DAS Star is something only a Stealership would have,... clone STAR are available.

Car battery should be changed every 5 years.

When you checked and pulled fuses,.... was the key in ignition,....
SunnyRayToronto is offline  
Old 10-03-2013, 04:32 AM
  #7  
MBWorld Fanatic!
 
Join Date: Jan 2005
Location: Orange County
Posts: 2,843
Likes: 0
Received 4 Likes on 4 Posts
2005 C Wagon (No snickering please!)
Depending on your VIN you might not have a brake switch...My car has cables to the shifter and the steering wheel lock. Maladjusted some things might not work.

You need to look at the shifter department to make sure there are no coins, debris, spilled beverages or the like that could be mucking up the works.

Failing a busted mechanical cable, or a soda soaked assembly (soak in alcohol to dissolve sugar) you are looking at an expensive VIN specific module. (Roughly a grand, they are all a grand for $40 worth of bits.)

Get a subscription to EPC, for free, and use your VIN to see how the brake pedal is connected to the module. You should probably be using Pelican Parts. They ship quick and have decent prices.

Good luck.
Moviela is offline  
Old 10-03-2013, 10:34 AM
  #8  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
Thank you everyone,,, still checking on these suggestions,,, honestly don't remember I'd the key was in or out,,,i believe out though,,,i had just drove out probably less than 30mins before i pulled the fuses? I have removed the trim ring on the shifter and everything there appears clean and normal? Please keep the suggestions coming,,,, I've seen where you can take a hammer and break the lock in the shifter to get it in gear but i hate to do that
bobby.gina is offline  
Old 10-03-2013, 10:35 AM
  #9  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
Like i said,, I've have about a two hr tow, just to get to "star"
bobby.gina is offline  
Old 10-03-2013, 04:25 PM
  #10  
MBWorld Fanatic!
 
Carsy's Avatar
 
Join Date: Mar 2008
Location: 1 hours drive north of Sydney Australia
Posts: 3,714
Received 42 Likes on 40 Posts
2007 W204 220CDI Classic Sedan
Originally Posted by bobby.gina View Post
Please keep the suggestions coming,,,, I've seen where you can take a hammer and break the lock in the shifter to get it in gear but i hate to do that
On my W204 I can remove the vinyl cover around the shifter & press a yellow switch at the rear to manually free it.Take a look in your hand book.

I would check your battery first . Its ancient.



JC
Carsy is offline  
Old 10-03-2013, 07:43 PM
  #11  
Newbie
Thread Starter
 
Join Date: Sep 2013
Posts: 7
Likes: 0
Received 1 Like on 1 Post
2004 c320 4matic
Thank you,, I will look that
bobby.gina is offline  
Old 04-28-2014, 05:23 PM
  #12  
Newbie
 
khellriegel's Avatar
 
Join Date: Mar 2014
Location: Kent, WA
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
1996 E320 4 Door Sedan
Hi-


Can you give us an update of what happened with your car?
khellriegel is offline  
Old 04-28-2014, 05:48 PM
  #13  
MBWorld Fanatic!
 
Join Date: Jul 2008
Posts: 6,743
Received 30 Likes on 27 Posts
2014 C350 Sport Sedan & 2015 Kia Optima Hybrid EX
Given that his was an 04 it was likely a brake switch. That is a typical culprit. Post 2005 W203s did not have brake switches.
LILBENZ230 is offline  
Old 12-12-2015, 11:28 AM
  #14  
Newbie
 
Join Date: Dec 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Mercedes s430 2000
Unhappy s430 year 2000

I have the very same problem on my s430 2000...
checked all 3 boxes of fuses...
changed the break switch too...
the problem still exist, moreover, I can't drive it to the dealer which is about 50 miles away..
Please any help.
Sam
sambal is offline  
Old 12-14-2015, 09:05 PM
  #15  
Super Moderator
 
samaritrey's Avatar
 
Join Date: Mar 2007
Location: McLean VA
Posts: 5,279
Likes: 0
Received 17 Likes on 16 Posts
THE C350
Post in the s class section as they may have a better idea of common issues with your car.

Last edited by samaritrey; 12-26-2015 at 12:17 AM.
samaritrey is offline  
Old 12-21-2015, 02:54 PM
  #16  
MBWorld Fanatic!
 
SeaCoupe's Avatar
 
Join Date: Jan 2006
Location: Pasadena, CA
Posts: 3,195
Likes: 0
Received 3 Likes on 3 Posts
2002 C230K, 2013 BMW 328, 2015 BMW X5
My 2002 C230 Coupe had this issue. The trans was stuck in Park. I disassembled the entire shifting console, no debris, nothing. I took out the Shifter and lo and behold without power being attached, it started shifting. I put another 100,000 miles on the car without ever having it happen again.
SeaCoupe is offline  
Old 12-23-2015, 12:18 PM
  #17  
Newbie
 
Join Date: Dec 2015
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Mercedes s430 2000
Question More explanation...

Originally Posted by SeaCoupe View Post
My 2002 C230 Coupe had this issue. The trans was stuck in Park. I disassembled the entire shifting console, no debris, nothing. I took out the Shifter and lo and behold without power being attached, it started shifting. I put another 100,000 miles on the car without ever having it happen again.
what is "lo"?
was your ABS lighting?
you just took the shifter off then reassembled it?
thanks
sambal is offline  
Old 07-02-2018, 04:00 PM
  #18  
Newbie
 
Join Date: Jul 2018
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
C320
Originally Posted by bobby.gina View Post
desperate need of some help please! Ok, i have a 2004 c320 4 matic. started out that the wipers and washer stopped working. so i assumed that a fuse was blown. i checked all the fuses in all three boxes trunk, under hood, driverside dash, all were good? i did pull all fuses out one at a time to check them. When i started the car back up i had a BAS/ESP light on dash and worse part the car is stuck in park? Also the brake light go to workshop code is there to and no interior lights? Im in a small town about 2 hrs from dealer? I have read nearly every thread on here concerning this problem and it all sounds like a brake light switch is the problem? So first of all there is nothing under my dash that looks like the switch shown on here. I also have been to parts house here and they list the same switch shown in these threads for the c320 but not the 4 matic? Is this different on my car and if so does anyone have any ideas? Im also assuming that the brake switch is not telling the shifter that the brake is pressed so it want let it go into gear? The brake lights do come on when the brake is pressed?
Thanks
Bobby
Having same problem with a 2004 C320 RWD and it doesn't have the switch either. How did you end up fixing it or does someone have any idea what it could be?
TedSay is offline  
 

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: STUCK IN PARK, BAS/ESP, BRAKE LIGHT GO TO WORKSHOP


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: