Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Ticking/Clicking noise during acceleration >

Ticking/Clicking noise during acceleration

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Ticking/Clicking noise during acceleration

 
Old 10-02-2013, 12:49 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
C300
Ticking/Clicking noise during acceleration

I have a 2008 C300 7AT, 60k miles. I recently found some high frequency clicking/ticking noise coming from the engine compartment when I accelerate a bit hard, especially at lower RPM (say <2k), but sometimes happens at >3k RPM too. The noise will be gone in 1-2 seconds, but often comes back when I step on gas hard again. I cannot duplicate it at idle by revving the engine. I have been always using premium gas.

Does anyone have similar issue?
raceway is offline  
Old 10-03-2013, 10:21 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
C300
Anyone? I also found that at hard acceleration, the noises comes up during the rpm dropping when the transmission upshifts.
raceway is offline  
Old 10-16-2013, 09:04 AM
  #3  
Newbie
 
Join Date: Mar 2012
Posts: 14
Likes: 0
Received 0 Likes on 0 Posts
2008 C300 Sport 4MATIC
Is it cold out when this is happening? More specifically... are you heating your car while this is happening? I have a similar noise in my car that I am 100% sure is the blower fan to my heating unit, only occurs when I am heating my car and during acceleration... something with the utility belt more than likely?
BenzTWM is offline  
Old 10-25-2013, 12:34 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Nov 2008
Posts: 65
Likes: 0
Received 0 Likes on 0 Posts
C300
Originally Posted by BenzTWM View Post
Is it cold out when this is happening? More specifically... are you heating your car while this is happening? I have a similar noise in my car that I am 100% sure is the blower fan to my heating unit, only occurs when I am heating my car and during acceleration... something with the utility belt more than likely?

no, it is there even i turned the fan off. i am suspecting the belt, but it does not make sense since i cannot create the noise when it is idle.
raceway is offline  
Old 01-26-2014, 02:05 PM
  #5  
Newbie
 
Join Date: Feb 2013
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Mercedes C 270 CDI
Originally Posted by raceway View Post
no, it is there even i turned the fan off. i am suspecting the belt, but it does not make sense since i cannot create the noise when it is idle.
Got something similar like you Raceway, constant annoying flaps noise at accelerating and decelerating. No noise when cold though, start flapping up when worming up. Can be from the gear box? Any help really appreciate.
dl94lopez is offline  
Old 01-26-2014, 02:47 PM
  #6  
MBWorld Fanatic!
 
Join Date: Apr 2012
Location: Calgary
Posts: 1,370
Likes: 0
Received 0 Likes on 0 Posts
C63 AMG
Im getting the same noise but only when I brake mostly at high speed sometimes at low speed braking.
snowmuch is offline  
Old 01-30-2014, 07:24 PM
  #7  
Newbie
 
Join Date: Jan 2014
Posts: 12
Likes: 0
Received 0 Likes on 0 Posts
2009 Mercedes C300 Sport
I know the original poster posted this question a while back but i used to have the same problem in my 2009 C300. I found that when I ran regular gas, the car would make a ticking sound when I accelerated hard. When I started using premium gas, the ticking completely went away. Occasionally, my wife will forget and fill it up with regular gas. When that happens the ticking sound come right back.
IncognitoSphinx is offline  
Old 01-30-2014, 07:38 PM
  #8  
Senior Member
 
mercedes4ever's Avatar
 
Join Date: Jan 2014
Posts: 311
Likes: 0
Received 0 Likes on 0 Posts
2004.7 C180 Kompressor, BMW X5, Chevrolet Camaro LT, Mercedes S, Cesna 152.
Wink

Originally Posted by raceway View Post
I have a 2008 C300 7AT, 60k miles. I recently found some high frequency clicking/ticking noise coming from the engine compartment when I accelerate a bit hard, especially at lower RPM (say <2k), but sometimes happens at >3k RPM too. The noise will be gone in 1-2 seconds, but often comes back when I step on gas hard again. I cannot duplicate it at idle by revving the engine. I have been always using premium gas.

Does anyone have similar issue?
Pinging or detonation, refer vid....
mercedes4ever is offline  
Old 01-30-2014, 11:28 PM
  #9  
Super Moderator
 
Glyn M Ruck's Avatar
 
Join Date: Jun 2008
Location: Llandudno, Cape Town, South Africa
Posts: 19,905
Received 94 Likes on 77 Posts
late 2009 CLK 350 Coupe Elegance, '65 Jaguar S Type wires
Knock, pinging, preignition, detonation by whatever name you know it. Should not happen with high octane fuel. Can be destructive.

When next at the dealer ask them to check that your ECU is set on a more forgiving map. So that it can adequately retard the timing when the knock sensor detects the onset of knock.

Only possible with a Star.
Glyn M Ruck is offline  
Old 01-07-2018, 03:36 PM
  #10  
Newbie
 
Join Date: Aug 2017
Posts: 11
Likes: 0
Received 0 Likes on 0 Posts
c300
Did you guys ever figure out what was causing it
Cesarek94 is offline  
Old 06-07-2019, 02:05 PM
  #11  
Newbie
 
Butterback's Avatar
 
Join Date: Oct 2018
Location: Washington D.C.
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
2015 Mercedes Benz C300 4Matic
Originally Posted by raceway View Post
I have a 2008 C300 7AT, 60k miles. I recently found some high frequency clicking/ticking noise coming from the engine compartment when I accelerate a bit hard, especially at lower RPM (say <2k), but sometimes happens at >3k RPM too. The noise will be gone in 1-2 seconds, but often comes back when I step on gas hard again. I cannot duplicate it at idle by revving the engine. I have been always using premium gas.

Does anyone have similar issue?

Exactly my issue with a 2015 C300.... When i accelerate hard, I hear a click/ticking sound right before it speeds up.
Butterback is offline  
 

Currently Active Users Viewing This Thread: 3 (0 members and 3 guests)
 

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: Ticking/Clicking noise during acceleration


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: