E300 Perfume - MBWorld.org Forums

Notices
E-Class (W213) 2016 -

E300 Perfume

Old 01-03-2018, 05:23 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
E300 Perfume

I just picked up my E300 yesterday and have the perfume set to medium in the car. Is the smell supposed to be hardly noticeable?? I think i smell it if i have the vents shooting out the air to the body section instead of the floor, but It might just be in my head.....? I am sure I have it turned on in the system.
jhpmbusa is offline  
Old 01-03-2018, 05:30 PM
  #2  
Member
 
Join Date: Apr 2011
Posts: 160
Thanked 5 Times in 5 Posts
2018 E300 4Matic.
It's subtle ... very subtle. Sometimes when you start the car ... but not always. Mine's also set to Medium.

At least you also get Air Ionization with Air Balance. I always leave it turned on.

I don't know what triggers perfume distribution, and how often. Does anyone know?

Last edited by bellavance; 01-03-2018 at 05:33 PM.
bellavance is offline  
Old 01-03-2018, 05:57 PM
  #3  
Member
 
Join Date: Aug 2014
Posts: 83
Thanks: 0
Thanked 4 Times in 4 Posts
E300
In my C300 that had it I noticed it often when I accerated. Also as Bellevance noted, when I started the car. There are some conditions though that are required, for example you can't have the "recirculate cabin air" button selected, and if I recall I had to have the driver's air vent open. You might look in the manual.
Latinnftl is offline  
Old 01-03-2018, 08:41 PM
  #4  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
put it on high on the ride home this evening, and not even a scent.... is there anything else I have to do other than turning it on through the system??
jhpmbusa is offline  
Old 01-03-2018, 09:41 PM
  #5  
Member
 
Join Date: Aug 2014
Posts: 83
Thanks: 0
Thanked 4 Times in 4 Posts
E300
Originally Posted by jhpmbusa View Post
put it on high on the ride home this evening, and not even a scent.... is there anything else I have to do other than turning it on through the system??
Silly as it sounds make sure you removed the plastic tape it might have had over the cap. Also you should hear it rise up when you close the glove compartment. As I mentioned you need to make sure you donít have it on recirculate. Make sure all vents are on and open. Turn off the ionizer and see if that makes the scent more noticeable.

Akso it took me forever to realize that I was turning it off. I have played with the control in the E but in the C the circular symbol it wasnít obvious that I had to have it set a certain way and if it wasnít it was actually off
Latinnftl is offline  
The Following User Says Thank You to Latinnftl For This Useful Post:
jhpmbusa (01-03-2018)
Old 01-03-2018, 10:08 PM
  #6  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
Originally Posted by Latinnftl View Post


Silly as it sounds make sure you removed the plastic tape it might have had over the cap. Also you should hear it rise up when you close the glove compartment. As I mentioned you need to make sure you donít have it on recirculate. Make sure all vents are on and open. Turn off the ionizer and see if that makes the scent more noticeable.

Akso it took me forever to realize that I was turning it off. I have played with the control in the E but in the C the circular symbol it wasnít obvious that I had to have it set a certain way and if it wasnít it was actually off

Will give it a try tomorrow! I believe I have the IONIZER on, hopefully when I turn it off it should work. What does the IONIZER do anyways lol?
jhpmbusa is offline  
Old 01-04-2018, 10:13 AM
  #7  
MBWorld Fanatic!
 
Egonvdv's Avatar
 
Join Date: Apr 2008
Location: A Dutchy Living in Marseille, France
Posts: 1,108
Thanked 93 Times in 76 Posts
W213 200CDI -Fascination
Originally Posted by jhpmbusa View Post
Will give it a try tomorrow! I believe I have the IONIZER on, hopefully when I turn it off it should work. What does the IONIZER do anyways lol?
the ionizer is a bit like god. if you believe in it it works :-)
Egonvdv is offline  
The Following 2 Users Say Thank You to Egonvdv For This Useful Post:
ABill (01-05-2018), jhpmbusa (01-04-2018)
Old 01-05-2018, 06:45 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
Originally Posted by Latinnftl View Post


Silly as it sounds make sure you removed the plastic tape it might have had over the cap. Also you should hear it rise up when you close the glove compartment. As I mentioned you need to make sure you donít have it on recirculate. Make sure all vents are on and open. Turn off the ionizer and see if that makes the scent more noticeable.

Akso it took me forever to realize that I was turning it off. I have played with the control in the E but in the C the circular symbol it wasnít obvious that I had to have it set a certain way and if it wasnít it was actually off
Still doesnt work.... maybe i have to bring it in for warranty....
jhpmbusa is offline  
Old 01-06-2018, 07:53 AM
  #9  
Junior Member
 
Join Date: Nov 2017
Posts: 35
Thanked 1 Time in 1 Post
2018 E-300
I could not smell any perfume in my new car. The dealer looked at it and send it was working just fine. I still could not smell anything, It would be better to buy a $1.95 pine tree smelly thing and have the extra space in the glove box.
704set is offline  
Old 01-09-2018, 08:02 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
Originally Posted by 704set View Post
I could not smell any perfume in my new car. The dealer looked at it and send it was working just fine. I still could not smell anything, It would be better to buy a $1.95 pine tree smelly thing and have the extra space in the glove box.

So I finally gave the dealership a call today. Seems like it works when I put in on AUTO. For those that said it works do you guys leave the air/heat on AUTO?
jhpmbusa is offline  
Old 01-09-2018, 08:25 PM
  #11  
Junior Member
 
Join Date: Nov 2017
Posts: 35
Thanked 1 Time in 1 Post
2018 E-300
Originally Posted by jhpmbusa View Post
So I finally gave the dealership a call today. Seems like it works when I put in on AUTO. For those that said it works do you guys leave the air/heat on AUTO?
Where is the AUTO that you are referring about? I can see high, med, low and off under air filter.

Thanks,
704sey
704set is offline  
Old 01-09-2018, 08:46 PM
  #12  
Senior Member
 
Cao Black's Avatar
 
Join Date: Nov 2013
Posts: 350
Thanked 37 Times in 33 Posts
2018 E300 P2 & 2015 ML350
Originally Posted by 704set View Post
Where is the AUTO that you are referring about? I can see high, med, low and off under air filter.

Thanks,
704sey
Set your Climate Control to Auto.

Cao Black is online now  
Old 01-09-2018, 09:18 PM
  #13  
Junior Member
 
Join Date: Nov 2017
Posts: 35
Thanked 1 Time in 1 Post
2018 E-300
Oh, that AUTO. I always have the Auto on and it doesn't seem to affect the perfume. I don't think I will be spending $95 for a perfume refill when the $1.95 pine tree works better.

Thanks.
704set is offline  
Old 01-09-2018, 11:00 PM
  #14  
Member
 
Join Date: Aug 2014
Posts: 83
Thanks: 0
Thanked 4 Times in 4 Posts
E300
Originally Posted by jhpmbusa View Post
So I finally gave the dealership a call today. Seems like it works when I put in on AUTO. For those that said it works do you guys leave the air/heat on AUTO?
Yes, it's also noted in the manual (page 125 of the manual): "Automatic climate control is activated." As I said earlier in the thread, it takes a whole set of conditions for the Airmatic to work. It does work though. I purchase my own scents and use the refillable bottle. Using white vinegar and coffee beans between scents to try to reduce the previous scents effects. As for the $1.95 freshner mentioned later, yeah no I'm not putting a $1.95 freshner in my 86K car.
Latinnftl is offline  
Old 01-09-2018, 11:43 PM
  #15  
Senior Member
 
Cao Black's Avatar
 
Join Date: Nov 2013
Posts: 350
Thanked 37 Times in 33 Posts
2018 E300 P2 & 2015 ML350
Originally Posted by 704set View Post
Oh, that AUTO. I always have the Auto on and it doesn't seem to affect the perfume. I don't think I will be spending $95 for a perfume refill when the $1.95 pine tree works better.

Thanks.
Will you be hanging the tree from the rear view mirror?

Silver lining...if you wait until it is empty before spending the $95 replacement cost...well, you get the picture.
Cao Black is online now  
Old 01-10-2018, 11:13 AM
  #16  
Junior Member
 
Join Date: Nov 2017
Posts: 35
Thanked 1 Time in 1 Post
2018 E-300
Originally Posted by Latinnftl View Post
Yes, it's also noted in the manual (page 125 of the manual): "Automatic climate control is activated." As I said earlier in the thread, it takes a whole set of conditions for the Airmatic to work. It does work though. I purchase my own scents and use the refillable bottle. Using white vinegar and coffee beans between scents to try to reduce the previous scents effects. As for the $1.95 freshner mentioned later, yeah no I'm not putting a $1.95 freshner in my 86K car.
What type of scents work by refilling the bottle.
And you are correct about putting a $1.95 pine tree freshner in a $86K car. Next time I'm putting in an entire pine tree for $95.

704set
704set is offline  
Old 06-22-2018, 07:16 AM
  #17  
Member
 
Join Date: Jun 2002
Posts: 243
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by jhpmbusa View Post
So I finally gave the dealership a call today. Seems like it works when I put in on AUTO. For those that said it works do you guys leave the air/heat on AUTO?
Did you get this working? There are a few cases where the scent hose behind the glove compartment got pinched during assembly thereby preventing the scent from coming out of the vents.
Petmerctech is offline  
Old 06-22-2018, 12:21 PM
  #18  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
Originally Posted by Petmerctech View Post
Did you get this working? There are a few cases where the scent hose behind the glove compartment got pinched during assembly thereby preventing the scent from coming out of the vents.

oh excellent! yes i still feel like my issue hasn't been resolved. Whats the best way to tell the service department on fixing this issue???
jhpmbusa is offline  
Old 06-22-2018, 01:46 PM
  #19  
Senior Member
 
Cao Black's Avatar
 
Join Date: Nov 2013
Posts: 350
Thanked 37 Times in 33 Posts
2018 E300 P2 & 2015 ML350
Originally Posted by jhpmbusa View Post
Will give it a try tomorrow! I believe I have the IONIZER on, hopefully when I turn it off it should work. What does the IONIZER do anyways lol?
Ionizers (supposedly) improve air quality by removing particles from the air in the cabin. Separate from that is fragrance. I have my fragrance setting on low, and it works as expected, although I can't tell you how or when. Usually just after start up, and then at random times thereafter. Fireside (the default fragrance that come with the car) is gently emitted into the cabin. The odor lasts for a short time and is rather pleasant. i don't smoke or have pets in my car, so there isn't much to mask. BTW, I run my climate control on Auto nearly all the time, set at 70.

Last edited by Cao Black; 06-23-2018 at 12:49 AM.
Cao Black is online now  
Old 06-23-2018, 11:07 AM
  #20  
Member
 
Join Date: Jun 2002
Posts: 243
Thanks: 0
Thanked 1 Time in 1 Post
Originally Posted by jhpmbusa View Post
oh excellent! yes i still feel like my issue hasn't been resolved. Whats the best way to tell the service department on fixing this issue???
First of all, is it working for you? You said in a post above that it seems to work in AUTO mode?

Try following the instructions on page 125 of your operator's manual again first under Perfume atomizer

Setting the fragrance system

Requirements


R Automatic climate control is activated.

R The glove box is closed.

Multimedia system: Vehicle --> Climate Control --> Air Freshener

To set the intensity: select HIGH, MEDIUM, LOW, or OFF

Try that first and see if you can smell it. Even on the low setting, the scent is noticeable unless your sense of smell is severely impaired. If you still don't smell the scent, request your dealer to check it again and say that it's not working. Tell your service advisor that you've heard of cases where the scent hose was pinched during assembly and have the tech or even better, the shop foreman, research the issue in his resources as it's not an official MB service bulletin. He should know where to look for the cases and remove the glove box to check the scent hose.
Petmerctech is offline  
Old 07-29-2018, 07:29 PM
  #21  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
Originally Posted by Petmerctech View Post
First of all, is it working for you? You said in a post above that it seems to work in AUTO mode?

Try following the instructions on page 125 of your operator's manual again first under Perfume atomizer

Setting the fragrance system

Requirements


R Automatic climate control is activated.

R The glove box is closed.

Multimedia system: Vehicle --> Climate Control --> Air Freshener

To set the intensity: select HIGH, MEDIUM, LOW, or OFF

Try that first and see if you can smell it. Even on the low setting, the scent is noticeable unless your sense of smell is severely impaired. If you still don't smell the scent, request your dealer to check it again and say that it's not working. Tell your service advisor that you've heard of cases where the scent hose was pinched during assembly and have the tech or even better, the shop foreman, research the issue in his resources as it's not an official MB service bulletin. He should know where to look for the cases and remove the glove box to check the scent hose.

Just got my car back after 3 weeks, states that the perfume is working as its designed. Still not a single smell after having it all weekend long. Is it possible for me to fix on my own?
jhpmbusa is offline  
Old 08-03-2018, 05:12 PM
  #22  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
after 2 visits to service still no luck. today they gave me a brand new bottle. just drove home.. like 3 miles... still no scent at all...
jhpmbusa is offline  
Old 08-03-2018, 05:25 PM
  #23  
MBWorld Fanatic!
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,026
Thanked 251 Times in 209 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by jhpmbusa View Post
after 2 visits to service still no luck. today they gave me a brand new bottle. just drove home.. like 3 miles... still no scent at all...
Put it on high in settings and see if you can smell it. For us, it was too prominent in High, so we backed it down to low and it's there, but just barely as I think it should be.
rbrylaw is offline  
Old 08-03-2018, 06:07 PM
  #24  
Senior Member
Thread Starter
 
Join Date: Oct 2017
Posts: 278
Thanked 11 Times in 11 Posts
e300
yepp. definitely on high and nothing. will try again later tonight.
jhpmbusa is offline  
Old 08-03-2018, 06:11 PM
  #25  
MBWorld Fanatic!
 
rbrylaw's Avatar
 
Join Date: Aug 2004
Location: Tampa, FL
Posts: 3,026
Thanked 251 Times in 209 Posts
2019 E450 4Matic & 2018 E400 4Matic
Originally Posted by jhpmbusa View Post
yepp. definitely on high and nothing. will try again later tonight.
Is it possible you just have difficulty smelling scents? Some people may not be able to smell things other's can easily smell. It shouldn't be overwhelming. It should be a mild scent.
rbrylaw is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: E300 Perfume


Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: