Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W213)
W213 Retrofitting Full screen LCD - minor issue >

W213 Retrofitting Full screen LCD - minor issue

Notices
E-Class (W213) 2016 -

W213 Retrofitting Full screen LCD - minor issue

 
Old 03-13-2019, 06:05 AM
  #1  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Talking W213 Retrofitting Full screen LCD - minor issue


Pre installation; Old setup

Mounted new LCD - BEFORE CODING

AFTER CODING THE SCREEN
Hey all,

I am new to MB altogether, was always a loyal BMW driver, but my last car was so problematic that I decided to switch.
The local dealer where I got the Beamer had this W213 and i liked it, some paperwork and we swapped keys.

There was just one thing, IT DOESNT HAVE A LARGE FULL SCREEN LCD?(WHAT WAS MB THINKING?)

Oh well, retrofitting time.

So far?

- Full screen LCD
- NTG 5.5 High
- New multimedia Module with a phone symbol(so i guess its high line)
- Cable for the Multimedia module
- wire harness for the ambient lighting
- Did the coding

Results so far:

Screen left side (LCD) working properly, responding to steering wheel, speedo, rpm and everything is working
Right side(LCD). pitch black, i hear a sound for 1 sec and then nothing?

Does anyone have the slightest clue? because i'm out of idea's...
Acho330 is online now  
Old 03-13-2019, 05:25 PM
  #2  
Junior Member
 
SCRL's Avatar
 
Join Date: Apr 2018
Location: Cambridge, UK
Posts: 29
Thanked 6 Times in 6 Posts
W213 E220d
Is there nothing AT ALL? Is the backlight even on? (Maybe try looking at it from an angle when it’s otherwise pitch black outside.)

There should be an annoying splash screen at start up. I assume you’re not getting that or you’d have said...

Are you able to control functions that would normally be visible on that screen even though the screen is black?

I’m sure you’ve Googled and watched the various videos like this one for clues?


Last edited by SCRL; 03-13-2019 at 05:30 PM.
SCRL is offline  
Old 03-13-2019, 05:50 PM
  #3  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by SCRL View Post
Is there nothing AT ALL? Is the backlight even on? (Maybe try looking at it from an angle when it’s otherwise pitch black outside.)

There should be an annoying splash screen at start up. I assume you’re not getting that or you’d have said...

Are you able to control functions that would normally be visible on that screen even though the screen is black?

I’m sure you’ve Googled and watched the various videos like this one for clues?

https://www.youtube.com/watch?v=dfbQpRo_8_M
Nope, nothing at all.

Searched the internet in all the languages I master. So far i googled in Arabic, French, German, English, Dutch with zero results.

(well zero is not true, because i got the left side to work, with all that info)

right side is the moneymaker, its the part where retrofitting companies make their money.

But to answer directly. Yes pitch black, all angels, its hard to control it when there no video.

PS i dont even know for sure if the NTG (navigation computer is on)
Acho330 is online now  
Old 03-13-2019, 06:23 PM
  #4  
Junior Member
 
SCRL's Avatar
 
Join Date: Apr 2018
Location: Cambridge, UK
Posts: 29
Thanked 6 Times in 6 Posts
W213 E220d
Originally Posted by Acho330 View Post
PS i dont even know for sure if the NTG (navigation computer is on)
That bit at least should be testable on the main screen (at least in terms of whether a map is displayed), or even through the voice control from the steering wheel. Just press and release the voice button, wait until it beeps, and then say “navigate to..” and some location.
SCRL is offline  
Old 03-14-2019, 03:38 AM
  #5  
MBWorld Fanatic!
 
vic viper's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 3,087
Thanked 196 Times in 127 Posts
S213
Is it coded correctly?, who did the coding and retrofit?
vic viper is online now  
Old 03-14-2019, 03:52 AM
  #6  
Junior Member
 
SCRL's Avatar
 
Join Date: Apr 2018
Location: Cambridge, UK
Posts: 29
Thanked 6 Times in 6 Posts
W213 E220d
...and really stupid question: is the on/off switch (in the centre console) working? I tried mine out this morning; it's COMPLETELY black when switched off, but there is a backlight glow when switched on, even before the splash screen appears.
SCRL is offline  
Old 03-14-2019, 04:52 AM
  #7  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by vic viper View Post
Is it coded correctly?, who did the coding and retrofit?
it should at least light up, or do something, right?. Left side is working, power is connected, because there is just 1 power inlet on the assembly.

The wires are all in the right place. (It’s almost 1 on 1)I just added the multimedia module and the wires to connect it.

So im guessing hardware is OK, software maybe, but even if its software, at least backlight should work?
Acho330 is online now  
Old 03-14-2019, 04:54 AM
  #8  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by SCRL View Post
...and really stupid question: is the on/off switch (in the centre console) working? I tried mine out this morning; it's COMPLETELY black when switched off, but there is a backlight glow when switched on, even before the splash screen appears.
You mean the large standby symbol button? Just under the scrolling wheel right? Yes, it works. Problem elsewhere im afraid.

Thanks btw for your replies, it means alot.
Acho330 is online now  
Old 03-14-2019, 06:18 AM
  #9  
MBWorld Fanatic!
 
vic viper's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 3,087
Thanked 196 Times in 127 Posts
S213
Originally Posted by Acho330 View Post
it should at least light up, or do something, right?. Left side is working, power is connected, because there is just 1 power inlet on the assembly.

The wires are all in the right place. (It’s almost 1 on 1)I just added the multimedia module and the wires to connect it.

So im guessing hardware is OK, software maybe, but even if its software, at least backlight should work?

Did you buy the panel new, used?, is it confirmed working?
Do you have the possibibilty to borrow and swap panels from another vehicle?
vic viper is online now  
Old 03-14-2019, 07:17 AM
  #10  
Senior Member
 
stephos's Avatar
 
Join Date: Nov 2018
Location: UK
Posts: 381
Thanked 34 Times in 33 Posts
MY19 E450 4MATIC Coupé
Acho330 you're brave to take on a project like this.

I'm following this thread in the hopes you get it sorted and fully operational.
stephos is online now  
Old 03-14-2019, 08:34 AM
  #11  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by vic viper View Post
Did you buy the panel new, used?, is it confirmed working?
Do you have the possibibilty to borrow and swap panels from another vehicle?
I’m afraid we lack brave souls who are willing to co-operate with my madness😂

new panel, used one would be a hassle. Its weird, all fakra cables 12v. The canbus high/low is 2.2 and 2.6 so thats good.. but no reaction from the right screen.

Im searching for a donor vehical, but as you guys can figure, no one is willing to help.
Acho330 is online now  
Old 03-14-2019, 11:18 AM
  #12  
MBWorld Fanatic!
 
vic viper's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 3,087
Thanked 196 Times in 127 Posts
S213

Display wiring diagram.
vic viper is online now  
Old 03-15-2019, 02:17 AM
  #13  
Member
 
Join Date: Apr 2018
Location: Austin, TX
Posts: 148
Thanked 42 Times in 34 Posts
E63 S Wagon
You're 100% certain that the NTG module is coded correctly?
wdimagineer is offline  
Old 03-15-2019, 05:33 AM
  #14  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by wdimagineer View Post
You're 100% certain that the NTG module is coded correctly?
Do you have experience coding it?


Possibilities atm:

- Screen is dead
- Coding wrong
- I am missing a wire somewhere? (but to be honest I checked so many schematics + it fits 1 on 1 now..)
- NTG is dead?

Last edited by Acho330; 03-15-2019 at 06:07 AM.
Acho330 is online now  
Old 03-15-2019, 06:06 AM
  #15  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by vic viper View Post

Display wiring diagram.
Quick question,

Could you explain what:

x30/35 & w34/w34/3 is?

Description is
x30/35 telematics CAN potential distributor?
w34 left footwell grounding point en w34/3 right footwell grounding point

But I really dont know what they are? And i'm assuming that K40 are the original factory wires, I don't have to modify them(as i'm converting from analog to digital)?
Acho330 is online now  
Old 03-15-2019, 11:13 AM
  #16  
MBWorld Fanatic!
 
vic viper's Avatar
 
Join Date: Mar 2009
Location: Sweden
Posts: 3,087
Thanked 196 Times in 127 Posts
S213
K40 is the fusebox providing +12V power,

X30/35 is a CAN group connection point, usually located under the footwell carpet.

W34 simple ground points.

As far as I can see the connections are all the same regardless of screen type, does your old screen work?
If it does my guess is that the new one is defective.
vic viper is online now  
Old 03-15-2019, 11:22 AM
  #17  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by vic viper View Post
K40 is the fusebox providing +12V power,

X30/35 is a CAN group connection point, usually located under the footwell carpet.

W34 simple ground points.

As far as I can see the connections are all the same regardless of screen type, does your old screen work?
If it does my guess is that the new one is defective.
old screen works, but thats with the old setup: ntg 5 audio 20, with small 8 inch lcd.

left side screen is functioning perfectly,, it makes it really hard to believe the right side is defective.
Acho330 is online now  
Old 03-15-2019, 11:34 AM
  #18  
Junior Member
 
SCRL's Avatar
 
Join Date: Apr 2018
Location: Cambridge, UK
Posts: 29
Thanked 6 Times in 6 Posts
W213 E220d
Originally Posted by Acho330 View Post
- NTG is dead?
Is that not testable by triggering navigation from the left screen and/or through voice control?
SCRL is offline  
Old 03-15-2019, 11:50 AM
  #19  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by SCRL View Post
Is that not testable by triggering navigation from the left screen and/or through voice control?
Nope, isn’t working.
Acho330 is online now  
Old 03-15-2019, 12:16 PM
  #20  
Junior Member
 
SCRL's Avatar
 
Join Date: Apr 2018
Location: Cambridge, UK
Posts: 29
Thanked 6 Times in 6 Posts
W213 E220d
Does the attached photo help at all? (Look at it in a mirror if my RHD car confuses the issue!)

The unit is turned off (button on centre console), but the ignition is on all the way. It shows a couple of potentially interesting things:

(1) When you flick the temperature control as I did just before the photo, the HVAC system displays its settings briefly at the bottom of the (otherwise blank) display. Does yours do this?

(2) The screen behind the steering wheel is telling us the unit is off because it says (Radio off). If the system was on, it would be displaying the current radio station and playing it. Can you get yours to reflect this change of state (by tapping the button on the centre console) even though your screen remains stubbornly blank?



I don't know whether any of this is of any use to you, but as an engineer I'm an inveterate debugger!
SCRL is offline  
The Following User Says Thank You to SCRL For This Useful Post:
stephos (03-18-2019)
Old 03-18-2019, 08:57 AM
  #21  
Senior Member
 
stephos's Avatar
 
Join Date: Nov 2018
Location: UK
Posts: 381
Thanked 34 Times in 33 Posts
MY19 E450 4MATIC Coupé
Good thinking SCRL and nicely illustrated. I'm hoping the OP comes back with an answer to your questions.
stephos is online now  
Old 03-18-2019, 02:48 PM
  #22  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by SCRL View Post
Does the attached photo help at all? (Look at it in a mirror if my RHD car confuses the issue!)

The unit is turned off (button on centre console), but the ignition is on all the way. It shows a couple of potentially interesting things:

(1) When you flick the temperature control as I did just before the photo, the HVAC system displays its settings briefly at the bottom of the (otherwise blank) display. Does yours do this?

(2) The screen behind the steering wheel is telling us the unit is off because it says (Radio off). If the system was on, it would be displaying the current radio station and playing it. Can you get yours to reflect this change of state (by tapping the button on the centre console) even though your screen remains stubbornly blank?



I don't know whether any of this is of any use to you, but as an engineer I'm an inveterate debugger!
Doesn’t do anything. Sorry guys this weekend I was abroad for business.

but we have a diag.

can anyone shed some light....


Acho330 is online now  
Old Today, 10:51 AM
  #23  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Wire was damaged, did some improvising an voila. Tomorrow a new cable will be delivered and were done

My thanks go out to SCRL and vic viper

DAMAGED THE AIR VENTS BADLY

Acho330 is online now  
Old Today, 10:54 AM
  #24  
Senior Member
 
stephos's Avatar
 
Join Date: Nov 2018
Location: UK
Posts: 381
Thanked 34 Times in 33 Posts
MY19 E450 4MATIC Coupé
That's great news (not about the vents - although I reckon, you'll probably be upgrading those next ).
stephos is online now  
Old Today, 10:59 AM
  #25  
Newbie
Thread Starter
 
Join Date: Mar 2019
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
w213 e220d
Originally Posted by stephos View Post
That's great news (not about the vents - although I reckon, you'll probably be upgrading those next ).
I saw the LED Variant, and I loved them, but they are over 400 euros. That's a bit to much for plastic.
Acho330 is online now  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 0 votes,  average.

Quick Reply: W213 Retrofitting Full screen LCD - minor issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: