Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > C-Class (W204)
Android 10.25 Screen Unit >

Android 10.25 Screen Unit

Notices
C-Class (W204) 2008 - 2014: C180K, C200K, C230, C280, C300, C350, C200CDI, C220CDI, C320CDI

Android 10.25 Screen Unit

 
Old 12-11-2018, 12:13 PM
  #226  
Newbie
 
rvanderwerf's Avatar
 
Join Date: Jan 2018
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
09 w204 c63, 08 G35 6mt Sedan
that's only for the facelift models that already have the screen in the dash.
rvanderwerf is offline  
Old 12-11-2018, 12:16 PM
  #227  
Super Member
 
97 GSX 97's Avatar
 
Join Date: May 2016
Location: Perkasie, PA
Posts: 535
Thanks: 0
Thanked 39 Times in 38 Posts
2014 C300 Sport
Originally Posted by rvanderwerf View Post
that's only for the facelift models that already have the screen in the dash.
I have a facelift 2014 and the small non command screen already.
97 GSX 97 is offline  
Old 12-13-2018, 03:15 AM
  #228  
Newbie
 
Join Date: Dec 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
W204 C250 AMG
Hello!

Does anybody know if it is possible to edit the original menu that the Android screen comes with. For example, to delete the ´Music' and ´Video´ links or change them to link to other apps?

I can´t seem to edit anything.
ph1lware is offline  
Old 12-13-2018, 07:00 AM
  #229  
Newbie
 
Join Date: Dec 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
W204 C250 AMG
Originally Posted by rahail1000 View Post
I have an issue with the 10,25" large screen for W212 from 2010. when using android, I only have voice on front left speaker. Has anyone experienced similar issue? I am using AUX MMI cable (which came along with the unit) and at one point I had voice on all speakers and without changing anything it is back to one speaker (left front) and nothing I can do to make it play on all speakers. When using OEM all speakers works.

Also, I have an issue with boot, sometime I have the black screen (with the car logo on lane) on the right side and I need to touch the screen before the Mercedes Benz startup logo starts.

Please help, thanks a lot.
Did you ever fix your issue with sound only from front left speaker? I am having the same problem.
ph1lware is offline  
Old 12-13-2018, 05:55 PM
  #230  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
Originally Posted by ph1lware View Post
Did you ever fix your issue with sound only from front left speaker? I am having the same problem.
Hi, this could be my first post so consider yourself special . I had this issue, I had messed with the order of the icons on the launcher and added the radio icon (which doesn't work on the newer unit anyway), as soon as I removed the radio icon in the launcher the problem went away...
Apoth is offline  
Old 12-13-2018, 06:02 PM
  #231  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
Originally Posted by ph1lware View Post
Hello!

Does anybody know if it is possible to edit the original menu that the Android screen comes with. For example, to delete the ´Music' and ´Video´ links or change them to link to other apps?

I can´t seem to edit anything.
You can move some stuff around but the launcher is pretty basic, you can't add Android Apps to the front screen. This video gives you some info:
Apoth is offline  
Old 12-14-2018, 01:09 AM
  #232  
Newbie
 
Join Date: Dec 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
W204 C250 AMG
Originally Posted by Apoth View Post
Hi, this could be my first post so consider yourself special . I had this issue, I had messed with the order of the icons on the launcher and added the radio icon (which doesn't work on the newer unit anyway), as soon as I removed the radio icon in the launcher the problem went away...
Thanks for your reply! Yes, this is also what I’ve done. I wish I hadn’t had entered that menu! How do you delete the icons once you’ve added them? I can’t see how to remove them, only add new ones!
Philip Ware is offline  
Old 12-14-2018, 01:43 AM
  #233  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
Originally Posted by Philip Ware View Post

Thanks for your reply! Yes, this is also what I’ve done. I wish I hadn’t had entered that menu! How do you delete the icons once you’ve added them? I can’t see how to remove them, only add new ones!
Double tap the icon I think, that moves it to the unused left side. Either that or tap the icon then tap a space on the left side.
Apoth is offline  
Old 12-14-2018, 01:54 AM
  #234  
Newbie
 
Join Date: Dec 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
W204 C250 AMG
Originally Posted by Apoth View Post
Double tap the icon I think, that moves it to the unused left side. Either that or tap the icon then tap a space on the left side.
Fixed! Thanks so much for your help, really appreciate it.
Philip Ware is offline  
Old 12-14-2018, 03:48 AM
  #235  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Never mess with the secret menus...
Chris The Swede is offline  
Old 12-14-2018, 03:57 AM
  #236  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
Originally Posted by Chris The Swede View Post
Never mess with the secret menus...
normally I would agree but there are some pretty fundamental options in the "secret menus" that should never have been there in the first place(volume adjustments, boot animations, moving the order of the icons on the main screen etc.) If the radio option causes such an issue it should have been removed completely, not hidden away 😀
Apoth is offline  
Old 12-17-2018, 01:36 PM
  #237  
Senior Member
 
Nicholi2007's Avatar
 
Join Date: Jun 2007
Location: Los Angeles, CA
Posts: 336
Thanked 1 Time in 1 Post
2009 C350
Originally Posted by aznmode View Post
So far it's worth it for me. My car is 2010 and this makes it feel like a 2018 car. I really hoping I can get around the short coming I mentioned.
If you want HD Radio, you still have to upgrade the Sirius Tuner, correct? Mine is a 2009 C350.
Nicholi2007 is offline  
Old 12-17-2018, 01:44 PM
  #238  
Senior Member
 
Join Date: Mar 2010
Location: Hollywood, CA
Posts: 257
Thanked 25 Times in 19 Posts
Tectitgrau S210
Originally Posted by Apoth View Post
normally I would agree but there are some pretty fundamental options in the "secret menus" that should never have been there in the first place(volume adjustments, boot animations, moving the order of the icons on the main screen etc.) If the radio option causes such an issue it should have been removed completely, not hidden away 😀
how do you move the icons around on the main screen? I was only able to remove the screen mirroring icon, but not move the other icons around. I wanna put CarPlay as my first icon.
Ungarisch is offline  
Old 12-17-2018, 02:29 PM
  #239  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
Originally Posted by Ungarisch View Post
how do you move the icons around on the main screen? I was only able to remove the screen mirroring icon, but not move the other icons around. I wanna put CarPlay as my first icon.
Do you know how to get into the secret menu?

Once you are in click Menu icon, follow what Raymond says in the above video. Take note of what he says about adding stuff (learned that one the hard way ).



Apoth is offline  
Old 12-17-2018, 02:41 PM
  #240  
Senior Member
 
Join Date: Mar 2010
Location: Hollywood, CA
Posts: 257
Thanked 25 Times in 19 Posts
Tectitgrau S210
yeah, I went in there and was able to remove the Mirror Link icon because I have no use for it, but even after I placed Carplay to the front slot it still shows up on the 2nd page of icons.

EDIT: Maybe I can remove all, save, then re-add them one by one in the order that I want them. Just worried about goofing up the home screen and then needing a reset, which I dont wanna do now that I have 20GB of songs downloaded to Spotify.
Ungarisch is offline  
Old 12-17-2018, 03:17 PM
  #241  
Newbie
 
Join Date: Jul 2018
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
C63
weird, I just went into the menu and moved icons around no problem, I click save and it prompts for a reboot and once it comes back online the icons are in the new spots?
Apoth is offline  
Old 12-17-2018, 03:32 PM
  #242  
Newbie
 
rvanderwerf's Avatar
 
Join Date: Jan 2018
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
09 w204 c63, 08 G35 6mt Sedan
So when it's all said and done was it worth it getting the 10.25 screen unit? Eyeballing the latest 4gb ram.64gb storage one. I'm wondering if the whole thing becomes 'meh' after the novelty wears off. I know my pfl 09 63 could use a tech upgrade!
rvanderwerf is offline  
Old 12-17-2018, 03:47 PM
  #243  
Senior Member
 
Join Date: Mar 2010
Location: Hollywood, CA
Posts: 257
Thanked 25 Times in 19 Posts
Tectitgrau S210
Originally Posted by Apoth View Post
weird, I just went into the menu and moved icons around no problem, I click save and it prompts for a reboot and once it comes back online the icons are in the new spots?
it did not ask me to reboot, so maybe I did it wrong. I'll try again.

Do you know if there is a way to re-assign the "Music" icon from the MP3 player to the spotify app? I know you can re-assign the Map icon to be Waze.
Ungarisch is offline  
Old 12-28-2018, 07:21 AM
  #244  
Senior Member
 
Join Date: Feb 2016
Location: UK
Posts: 391
Thanked 45 Times in 41 Posts
E250 AMG Sport Convertible
You can't re-assign it as it is built into the launcher app and only uses a portion of the screen. a 3rd party one would run full screen.
400ixl is offline  
Old 01-11-2019, 10:10 PM
  #245  
Newbie
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
W204 c250
Help needed please

ReHi guys,

Need to ask a favour please, while fitting my kids walked off with the screws and can't find them! Please can somebody tell me the size / thread of the 2 screws re-used from the original MB screen for the new mounting bracket, and also the screws to secure the screen to the bracket and stop the rattle noise.

Really appreciate the help!
anon_uk is offline  
Old 01-12-2019, 07:30 AM
  #246  
Super Member
 
benzdude's Avatar
 
Join Date: Nov 2003
Location: Earth
Posts: 697
Thanked 35 Times in 35 Posts
2015 C300 4Matic Sport
Originally Posted by anon_uk View Post
ReHi guys,

Need to ask a favour please, while fitting my kids walked off with the screws and can't find them! Please can somebody tell me the size / thread of the 2 screws re-used from the original MB screen for the new mounting bracket, and also the screws to secure the screen to the bracket and stop the rattle noise.

Really appreciate the help!
YOU LOST YOUR KIDS!?
benzdude is offline  
Old 01-13-2019, 04:43 PM
  #247  
Newbie
 
Join Date: Jan 2019
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
W204 c250
Hi, I have 2 questions in regards to use of the screen to see if anybody can help

1) Currently, when I press the audio or video icon on the Home screen I get an error saying something like 'file not found' or 'unsupported media type'. Where can I go to set default apps for both of these?

2) Bluetooth, I want to pair a Bluetooth ODB-II adapter to Torque on the screen. BT is enabled, I can pair a mobile but Torque won't see the device (my mobile can see it). In Android Settings and Bluetooth, it only asks about auto connect etc. What am I missing, where can I go to pair the device please?

Thanks
anon_uk is offline  
Old 01-15-2019, 06:54 PM
  #248  
Junior Member
 
Join Date: Sep 2018
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes w205
Originally Posted by anon_uk View Post
Hi, I have 2 questions in regards to use of the screen to see if anybody can help

1) Currently, when I press the audio or video icon on the Home screen I get an error saying something like 'file not found' or 'unsupported media type'. Where can I go to set default apps for both of these?
As far as I know the only app that you can set is the one launched with the Navi. The error you see is because there is media to display. If you had a list of songs or videos you wouldn't see this error.

Originally Posted by anon_uk View Post
2) Bluetooth, I want to pair a Bluetooth ODB-II adapter to Torque on the screen. BT is enabled, I can pair a mobile but Torque won't see the device (my mobile can see it). In Android Settings and Bluetooth, it only asks about auto connect etc. What am I missing, where can I go to pair the device please?

Thanks
Somewhere, in the 1000 forums that are related to these displays I read that only a few ODB-II adapters are capable of connecting to this display. The majority of the adapter sold in AliExpress seem not to be supported. I remember somebody complaining why did they block the connection to them. It is a very vague information but that could help with a search starting point.
fgarcor is offline  
Old 01-15-2019, 07:01 PM
  #249  
Junior Member
 
Join Date: Sep 2018
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Mercedes w205
Originally Posted by anon_uk View Post
ReHi guys,

Need to ask a favour please, while fitting my kids walked off with the screws and can't find them! Please can somebody tell me the size / thread of the 2 screws re-used from the original MB screen for the new mounting bracket, and also the screws to secure the screen to the bracket and stop the rattle noise.

Really appreciate the help!
The following entry is in German, but he explains that the current screws and bolts don't hold enough and it is better to buy the M4 ones as a replacement. There is a picture of them in the thread at the beginning. Check the first post, right before the paragraph titled "Einbau".

Motor-Talk.de w212 Martins thread
fgarcor is offline  
Old 01-17-2019, 12:22 AM
  #250  
Senior Member
 
sentralfyr's Avatar
 
Join Date: Oct 2005
Location: Norway
Posts: 274
Thanked 11 Times in 11 Posts
2015 S205 AMG
Thumbs up

Originally Posted by aznmode View Post
So I bought a bluetooth OBDII scanner that plugs into my OBDII. This way I can see information such as RPM, speed, boost, temp etc on the screen. Except I can't get it to pair. When I go to my bluetooth setting, I see the OBDII on the list but when I try to pair, it won't pop up the screen to where I can enter the pairing code. Do you guys know of any bluetooth OBDII devices that do not require a pairing code?

This is the one I bought
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1

UPDATE: Solved my issue
Found this app to pre program pin code for bluetooth connections. Well worth the price tag for what I'm trying to accomplish.
https://play.google.com/store/apps/d...con.btautopair



I purchased Torque Pro from the play store and here is a screen shot.
https://play.google.com/store/apps/d...g.prowl.torque

Not sure I like the interface of Torque Pro so I will keep searching for one that I like.

Hi
Nice writeup
I have almost the same screen as you but a newer version.
I also like the OBDII and Torque, but the screen cant find my OBDII.
As far i can understand you just downloaded the "bluetooth auto pair" and installet Torque?
Can you see the bluetoothconnection on the screen?
Could you please tell me exactly what you did?
sentralfyr is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:

Quick Reply: Android 10.25 Screen Unit


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: