Go Back  MBWorld.org Forums > Mercedes-Benz Sedans > E-Class (W212)
10.25 inch android headunit installed >

10.25 inch android headunit installed

Notices
E-Class (W212) 2010 - 2016: E 350, E 550

10.25 inch android headunit installed

 
Old 05-23-2018, 06:07 PM
  #351  
Junior Member
 
Join Date: Apr 2017
Posts: 30
Thanked 3 Times in 2 Posts
2014 Mercedes-Benz E350 4Matic Sedan
Originally Posted by dsenela View Post
My thoughts exactly, and why I will not be buying the new unit especially if it is more expensive. The current unit is already way too expensive. 90% of issues plaguing this unit is software related and can easily be fixed via updates. There is no monetary incentive for the manufacturers in China to 'work' on updates when they could be selling new units with supposedly new features. The only hope is for the modding community to come up with mods that could somehow fix some of the current problems and improve functionality.. The unit is built to tightly integrate with our vehicles, and unfortunately the modding community base of people with resources to tinker with these units is very low. The hardware itself is really not bad, we just need a way to breath new life into it through better software.
Have any updates to the original firmware (on the original units) been released? Or are we still stuck with the original firmware that the unit shipped with.
I completely agree with the quote above.... so much potential for improvement ... but I have no idea if anyone will even bother tinkering with this. Maybe we get a gofundme campaign going....LOL
deepthought66 is offline  
Old 05-24-2018, 03:20 AM
  #352  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Many updates done. What are you looking for in a update?
Chris The Swede is offline  
Old 05-24-2018, 08:50 PM
  #353  
Member
 
Join Date: Sep 2015
Posts: 243
Thanked 6 Times in 6 Posts
2015 C300 Sport
Originally Posted by Chris The Swede View Post
Many updates done. What are you looking for in a update?
Still waiting on a response on why other screens have Android 7, but these can't have them...
ItchyTasty is offline  
Old 05-25-2018, 04:39 AM
  #354  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
The old ones can never have it since it cant handle it. There will never be a Android update for them. Just feature updates.
Chris The Swede is offline  
Old 05-25-2018, 09:17 AM
  #355  
Newbie
 
Join Date: May 2018
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
w176
And where can I get some of These Feature Updates?
On my headunit there is no possibility to control the brightness for example.
Fuchstiger is offline  
Old 05-25-2018, 10:40 AM
  #356  
Member
 
Join Date: Sep 2015
Posts: 243
Thanked 6 Times in 6 Posts
2015 C300 Sport
Originally Posted by Chris The Swede View Post
The old ones can never have it since it cant handle it. There will never be a Android update for them. Just feature updates.
Ok so the old ones can't have Android 7. Why can't this new one? If there are current screens with A7, and this one isn't out yet, it seems like it would be an easy call.
ItchyTasty is offline  
Old 05-25-2018, 01:47 PM
  #357  
MBWorld Fanatic!
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,309
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by Fuchstiger View Post
And where can I get some of These Feature Updates?
On my headunit there is no possibility to control the brightness for example.
Technically there is a brightness adjustment but it's such a minimal change you can only notice it if you do the adjustment at night. It's like a 10% increase in brightness. Possibly that was done to prevent the screen from dying too fast?
aznmode is offline  
Old 05-26-2018, 03:57 AM
  #358  
Newbie
 
Join Date: May 2007
Location: Cairo, Egypt
Posts: 8
Thanked 1 Time in 1 Post
Opel Vectra 1999
Thank You aznmode

Originally Posted by aznmode View Post
So I bought a bluetooth OBDII scanner that plugs into my OBDII. This way I can see information such as RPM, speed, boost, temp etc on the screen. Except I can't get it to pair. When I go to my bluetooth setting, I see the OBDII on the list but when I try to pair, it won't pop up the screen to where I can enter the pairing code. Do you guys know of any bluetooth OBDII devices that do not require a pairing code?

This is the one I bought
https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1


UPDATE: Solved my issue
Found this app to pre program pin code for bluetooth connections. Well worth the $1.99 price tag for what I'm trying to accomplish.
https://play.google.com/store/apps/d...con.btautopair



I purchased Torque Pro from the play store and here is a screen shot.
https://play.google.com/store/apps/d...g.prowl.torque

Not sure I like the interface of Torque Pro so I will keep searching for one that I like.

I've been searching for a solution and downloaded a couple pf apps for the same purpose that didn't work. With your suggestion I finally managed to pair my OBDII with the screen
ahegazi is offline  
The Following User Says Thank You to ahegazi For This Useful Post:
Perocat (10-19-2018)
Old 05-26-2018, 08:33 AM
  #359  
Member
 
Join Date: Nov 2017
Location: Ohio
Posts: 106
Thanks: 0
Thanked 6 Times in 6 Posts
CLS550, BMW 550
Originally Posted by Chris The Swede View Post
Screen is far from same hardware quality...
Excuses excuses! I take it you have one of those new screens? Otherwise how can you attest to the inferior hardware?
Gee_115 is offline  
Old 05-26-2018, 01:56 PM
  #360  
Member
 
Join Date: Sep 2015
Posts: 243
Thanked 6 Times in 6 Posts
2015 C300 Sport
Originally Posted by Gee_115 View Post
Excuses excuses! I take it you have one of those new screens? Otherwise how can you attest to the inferior hardware?
I mean dude resells Chinese sceens on his website. He has a vested interest in bashing the competition.
ItchyTasty is offline  
Old 05-26-2018, 02:13 PM
  #361  
MBWorld Fanatic!
 
aznmode's Avatar
 
Join Date: Aug 2007
Location: San Jose, CA
Posts: 1,309
Thanked 20 Times in 13 Posts
2010 c300
Originally Posted by ahegazi View Post
I've been searching for a solution and downloaded a couple pf apps for the same purpose that didn't work. With your suggestion I finally managed to pair my OBDII with the screen
Glad I could help!
aznmode is offline  
Old 05-28-2018, 02:47 AM
  #362  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Originally Posted by Fuchstiger View Post
And where can I get some of These Feature Updates?
On my headunit there is no possibility to control the brightness for example.
That we have an update for. My customers get it from me.
Chris The Swede is offline  
Old 05-28-2018, 02:50 AM
  #363  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Originally Posted by Gee_115 View Post
Excuses excuses! I take it you have one of those new screens? Otherwise how can you attest to the inferior hardware?
What???? And You clearly know what you are talking about!! New unit have "bigger" of all..So it can run the 6 smothely.
Chris The Swede is offline  
Old 05-29-2018, 04:53 PM
  #364  
Newbie
 
Join Date: May 2018
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
w212
Waze / Spotify Integration

Has anyone managed to get Waze and Spotify to work integrated i..e so you can change tracks in Waze ?
dimmi is offline  
Old 05-29-2018, 05:14 PM
  #365  
Senior Member
 
Join Date: Mar 2010
Location: Hollywood, CA
Posts: 257
Thanked 25 Times in 19 Posts
Tectitgrau S210
Originally Posted by dimmi View Post
Has anyone managed to get Waze and Spotify to work integrated i..e so you can change tracks in Waze ?
no, you cannot get it to work, there is a glitch is this particular head unit that is preventing the integration from working, sadly.
Ungarisch is offline  
Old 05-29-2018, 11:10 PM
  #366  
Junior Member
 
Join Date: Feb 2018
Location: Los Angeles
Posts: 37
Thanks: 0
Thanked 2 Times in 2 Posts
2014 Mercedes Benz E350
Originally Posted by Chris The Swede View Post
That we have an update for. My customers get it from me.
Chris, where can I get the update? I purchased my unit from you as well.
Avilly is offline  
Old 05-30-2018, 02:46 AM
  #367  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Originally Posted by Avilly View Post


Chris, where can I get the update? I purchased my unit from you as well.
[email protected]
Chris The Swede is offline  
Old 05-30-2018, 12:51 PM
  #368  
Newbie
 
Join Date: May 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
e class es cdi
Smile Screen

Originally Posted by c240DUDE View Post
Do you happen to have a step-by-step procedure? I'm having trouble with a few things. I think I did everything correct, however, my stock COMAND is not displaying, my knob doesn't work with the new interface, my sound is not working even when I connected it through the aux connector. Chris sent me a PowerPoint of what I needed to do and yet again, it still doesn't work for me. Not sure what I'm doing wrong. Any help or feedback would be greatly appreciated.
What does your wife think about your Knob not working?.
oldgag is offline  
Old 05-30-2018, 03:46 PM
  #369  
Newbie
 
Join Date: May 2015
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
2012 CLS550 W218
No Audio From Android Touchscreen

Hi guys, I was hoping someone could help me with some troubleshooting. I can not get audio from the Touchscreen unit. I have plugged in the RCA cables to the Aux input under the armrest and changed the connection to Aux in the hidden menu and Aux on the Comand unit but still no sound. I have tried playing mp3's from the USB, Youtube app, Google Maps app and Bluetooth Streaming but I only get static and no sound . I can confirm I get sound from all my sources on the Comand unit.

Thanks in advance.
al_bundy23 is offline  
Old 06-02-2018, 03:53 PM
  #370  
Newbie
 
Join Date: Jun 2018
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
mercedes A class FL 13
Could anyone help me, recently purchased one of these finally got the screen installed today or so i tried. Like an idiot i've stumbled on this page (chris + others) after iv'e bought it and i know customer service is going to be a pain! Wish i went through chris or similar vendors you guys have.

basically the screen won't turn on at all when key goes in, and im 95% sure wires are all hooked up correct. can anyone tell me which wires i'll need to connect as a bare minimum to get something displayed on the screen?
I dont know which is the power cable for instance, if i plug that one in should i effectively be able to see something on the screen ( mercedes logo) anything! My car is an A class 2013 Model, running NTG 4.5 (NOT Command)

Just need help identifying i guess, any help! ive had to leave it out, unconnected

Kind regards,
Tvremote is offline  
Old 06-03-2018, 04:39 AM
  #371  
Banned
 
Join Date: Oct 2009
Location: Sweden, Stockholm
Posts: 3,306
Thanked 143 Times in 112 Posts
W212 E63 wagon, ML350, GLK 350
Never heard of. Should power up right away after adding it to stock conector.
Chris The Swede is offline  
Old 06-03-2018, 06:03 AM
  #372  
Newbie
 
Join Date: Jun 2018
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
mercedes A class FL 13
Originally Posted by Chris The Swede View Post
Never heard of. Should power up right away after adding it to stock conector.
is that the bigger sized one or the smaller square connector?
Tvremote is offline  
Old 06-03-2018, 10:31 AM
  #373  
Member
 
Join Date: Nov 2017
Location: Ohio
Posts: 106
Thanks: 0
Thanked 6 Times in 6 Posts
CLS550, BMW 550
Originally Posted by Tvremote View Post
is that the bigger sized one or the smaller square connector?
Why don't you just post pics? You said NTG4.5 not COMAND, that is COMAND. Maybe you have audio20?
Gee_115 is offline  
Old 06-03-2018, 07:48 PM
  #374  
Super Member
 
cocobeex's Avatar
 
Join Date: May 2014
Location: Vancouver B.C
Posts: 642
Thanked 37 Times in 32 Posts
2014 E550 4MATIC TUNED - Turbo Upgraded Stage 3
Originally Posted by Tvremote View Post
Could anyone help me, recently purchased one of these finally got the screen installed today or so i tried. Like an idiot i've stumbled on this page (chris + others) after iv'e bought it and i know customer service is going to be a pain! Wish i went through chris or similar vendors you guys have.

basically the screen won't turn on at all when key goes in, and im 95% sure wires are all hooked up correct. can anyone tell me which wires i'll need to connect as a bare minimum to get something displayed on the screen?
I dont know which is the power cable for instance, if i plug that one in should i effectively be able to see something on the screen ( mercedes logo) anything! My car is an A class 2013 Model, running NTG 4.5 (NOT Command)

Just need help identifying i guess, any help! ive had to leave it out, unconnected

Kind regards,
Or maybe its a defective unit ? DOA ?
cocobeex is offline  
Old 06-04-2018, 12:39 AM
  #375  
Newbie
 
Join Date: May 2018
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
w204 2011
Does anyone know where the language files are located?

I would love to be able to edit a few things.

First of all, that "pay attention to the around!" on the backup camera. It makes me crazy.

Thanks!!
guillermogc is offline  

Thread Tools
Search this Thread
Rate This Thread
Rate This Thread:
You have already rated this thread Rating: Thread Rating: 6 votes, 3.67 average.

Quick Reply: 10.25 inch android headunit installed


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: